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Preface

This guide describes how to use the Sun™ StorEdge™ Volume Manager Storage
Administrator. The Volume Manager Storage Administrator is the Graphical User
Interface (GUI) for the Volume Manager.

This guide is intended for system administrators responsible for configuring and
maintaining systems using the Sun StorEdge Volume Manager.

This guide assumes:

■ A basic understanding of system administration
■ A working knowledge of the UNIX operating system
■ Familiarity with the Sun StorEdge Volume Manager and related concepts

How This Book Is Organized
This guide is organized as follows:

■ Chapter 1 “Introduction,” describes the main components of the Volume Manager
Storage Administrator.

■ Chapter 2 “Getting Started,” describes how to set up and start using the Volume
Manager Storage Administrator.

■ Chapter 3 “Disk Tasks,” describes how to set up and use disks with the Volume
Manager Storage Administrator.

■ Chapter 4 “Volume Tasks,” describes how to create and use volumes with the
Volume Manager Storage Administrator.

The Glossary defines terms that relate to the Volume Manager Storage
Administrator.
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Using UNIX Commands
This document does not contain information on basic UNIX® commands and
procedures such as shutting down the system, booting the system, and configuring
devices.

See one or more of the following for this information:

■ Solaris 2.x Handbook for SMCC Peripherals

■ AnswerBook™ online documentation for the Solaris™ 2.x software environment

■ Other software documentation that you received with your system
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Typographic Conventions

Shell Prompts

TABLE P-1 Typographic Conventions

Typeface or
Symbol Meaning Examples

AaBbCc123 The names of commands, files,
and directories; on-screen
computer output.

Edit your .login  file.
Use ls -a  to list all files.
% You have mail .

AaBbCc123 What you type, when
contrasted with on-screen
computer output.

% su
Password:

AaBbCc123 Book titles, new words or terms,
words to be emphasized.
Command-line variable;
replace with a real name or
value.

Read Chapter 6 in the User’s Guide.
These are called class options.
You must be root  to do this.
To delete a file, type rm filename.

TABLE P-2 Shell Prompts

Shell Prompt

C shell machine_name%

C shell superuser machine_name#

Bourne shell and Korn shell $

Bourne shell and Korn shell superuser #
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Related Documentation

Sun Documentation on the Web
The docs.sun.com  web site enables you to access Sun technical documentation on
the Web. You can browse the docs.sun.com  archive or search for a specific book
title or subject at:

http://docs.sun.com

Sun Welcomes Your Comments
We are interested in improving our documentation and welcome your comments
and suggestions. You can email your comments to us at:

smcc-docs@sun.com

Please include the part number of your document in the subject line of your email.

TABLE P-3 Related Documentation

Title Part Number

Volume Manager Installation Guide 805-5707-10

Volume Manager Storage Administrator Release Notes 805-5710-10

Volume Manager System Administrator’s Guide 805-5706-10
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CHAPTER 1

Introduction

This chapter provides a brief introduction to the Sun StorEdge Volume Manager
Storage Administrator. This chapter describes the main components of the Storage
Administrator and contains a summary of common tasks.

The following topics are discussed in this chapter:

■ The Volume Manager Storage Administrator

■ The Main Window

■ Task Roadmap

■ Storage Administrator Icons

The Volume Manager Storage
Administrator
The Sun StorEdge Volume Manager Storage Administrator is the graphical user
interface (GUI) for Volume Manager. The Storage Administrator is an interface based
on the Java™ programming language that can be run from a Web browser or as a
Java application. The Storage Administrator allows you to administer disks,
volumes, and file systems on local or remote machines.

The Storage Administrator consists of a server and a client. The Storage
Administrator server runs on a UNIX machine that is running the Sun StorEdge
Volume Manager. The Storage Administrator client runs on any machine that
supports the Java Runtime Environment.
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Storage Administrator Features
The Volume Manager Storage Administrator provides the following features:

■ Ease of Use

The Storage Administrator is a task-based user interface that provides access to tasks
through menus or a task list. With the Storage Administrator, administrators can
easily navigate and configure their systems. Administrators can use the Storage
Administrator to browse through all of the objects on the system or view detailed
information about a specific object.

■ Remote Administration

With the Storage Administrator, administrators can perform Volume Manager
administration remotely or locally. The Storage Administrator client runs on UNIX
or Windows machines.

■ Java-Based Interface

The Storage Administrator client is a pure Java-based interface. Administrators can
run the Storage Administrator from a Web browser or as a Java application.

■ Scalability

The Storage Administrator can handle systems containing a large number of disks.
Administrators can view all of the objects on the system or focus on a specific object
or set of objects.

■ Security

The Storage Administrator can only be run by users with appropriate privileges.
Administrators can restrict the use of the Storage Administrator to a specific set of
users.
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The Main Window
The Volume Manager Storage Administrator’s main window (see Figure 1-1)
consists of:

■ a hierarchical tree of objects

■ a grid that lists objects and their properties

■ a menu bar

■ a toolbar

■ a status area

■ a Command Launcher (hidden by default)

The toolbar and Command Launcher can be separated from and reattached to the
main window (this is known as docking). The grid can be replicated in a separate
window.



4 Sun StorEdge Volume Manager Storage Administrator 1.0 User’s Guide • July 1998

FIGURE 1-1 Main Window

The Object Tree and Grid
The Storage Administrator’s main window is divided into two main panes:

■ Left Pane (Object Tree)

Menu Bar

Toolbar

Object Tree

Grid

Command
Launcher

Status Area

Splitter

(optional)

System
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The left pane contains the object tree, which is a dynamic hierarchical display of
Volume Manager objects and other objects on the system. Each node in the tree
represents a group of objects of the same type. Each object group has a group icon
and a group name. The system name is at the top of the tree.

The following object groups typically appear as nodes in the object tree:

■ Disk Groups — All disk groups on the system.

■ Disks — All disks on the system.

■ Volumes — All volumes on the system.

■ Controllers — All controllers on the system.

■ Free Disk Pool — Any disks that are under Volume Manager control, but do
not belong to a disk group.

■ Uninitialized Disks — Any disks that are not under Volume Manager control.

■ File Systems — All mounted file systems on the system.

You can expand these nodes (by clicking on the plus sign) to reveal the hierarchy
under each node. When you select a group icon (or node) in the object tree, objects of
that type appear in the right pane.

■ Right Pane (Grid)

The right pane contains a grid, which is a tabular display of objects and their
properties. The grid displays objects that belong to the group icon that is currently
selected in the object tree (left pane). The grid is dynamic and constantly updates its
contents to reflect changes to objects.

You can sort the contents of a property column in the grid by clicking on the column
heading. You can reverse the sort order by clicking on the column heading again.

The splitter is the vertical bar that separates the object tree from the grid. You can
resize the left and right panes by clicking on the splitter and dragging it to the left or
right.

The Menu Bar
The menu bar at the top of the main window contains the following menus:

■ Console

The Console menu closes the main window or exits the Storage Administrator.

■ Create

The Create menu creates volumes, disk groups, or file systems.

■ Options
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The Options menu provides access to the Preferences window and saves or loads
user preferences. The Preferences window displays and sets user preferences for the
components of the Storage Administrator.

■ Window

The Window menu opens (launches) another Storage Administrator main window,
the task request monitor, the alerts window, the search window, a copy of the main
grid, or the Command Launcher.

■ Selected (context sensitive)

The Selected menu is a context-sensitive menu that changes its name and menu
options when the selected object changes. By default, the Selected menu is greyed
out. When an object is selected, Selected is renamed and provides access to tasks
appropriate for the selected object. For example, Selected becomes Volumes when a
volume is selected. The Volumes menu provides access to volume tasks.

■ Help

The Help menu provides access to online help for the Storage Administrator.
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The Toolbar
The toolbar consists of a set of buttons that provide access to the following windows:

■ Volume Manager

The Volume Manager (VolMgr) button launches an additional Storage Administrator
main window.

■ Task

The Task button launches the Task Request Monitor window. The Task Request
Monitor window displays a list of tasks performed in the current session. Each task
is listed with the user who performed the task, the task status, and the start and
finish times for the task.

■ Alerts

The Alerts button displays the Alert Monitor window. The Alert Monitor window
identifies any objects that have experienced failures or errors and describes the
problem(s). When an object fails or experiences an error, an alert icon appears in the
status area of the main window and/or on the object’s icon.

■ Search

The Search button displays the Object Search window, which is used to search for
objects on the system. The Object Search window contains a set of tabbed pages,
each of which contains search options for a particular type of object.

The Dock button separates the toolbar from the main window or attaches the
separated toolbar to the main window.
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The Status Area
The status area of the main window is below the menu bar. When an object fails or
experiences some other error, an alert/error icon appears in the status area. The
Alert Monitor window provides details on the error. You can access the Alert
Monitor window by clicking on the alert icon in the status area.

The Command Launcher
The Command Launcher displays a list of tasks that can be performed on objects.
Each task is listed with the object type, task (action), and a description of the task.
When you click on a task in the Command Launcher list, the task is launched
(started) and the dialog box for the task appears.

The Command Launcher is hidden by default. You can display or hide the
Command Launcher by choosing Window > Command Launcher. You can separate
or attach the Command Launcher and the main window by choosing Options >
Preferences > Main Window and clicking Dock Command Launcher.

You can sort the items listed in the Command Launcher by object type, command, or
task description by clicking on the appropriate column heading. You can reverse the
sort order by clicking on the column heading again.
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Task Roadmap
This section provides a summary of common Volume Manager Storage
Administrator tasks. The tasks are grouped into preliminary installation and setup
tasks, ongoing maintenance tasks, and repair or recovery tasks. The procedures for
these and other tasks are included in later chapters.

Setup Tasks
If you are using the Volume Manager and the Storage Administrator for the first
time, you need to install both products, place your disks under Volume Manager
control, and create volumes (and file systems).

▼ To install and set up the Storage Administrator

Install the Volume Manager and run vxinstall  before you install the Storage
Administrator (see the Sun StorEdge Volume Manager Installation Guide for details).

■ Install the Storage Administrator.

■ Start the Storage Administrator.

These tasks are described in Chapter 2.

▼ To set up disks
■ Place uninitialized disks under Volume Manager control.

■ Create additional disk groups for the new disks (optional).

■ Designate one or more disks as hot-relocation spares (optional).

These tasks are described in Chapter 3.

▼ To create an alternate boot disk (optional)
■ Place the boot (root) disk under Volume Manager control and choose

encapsulation to convert the contents of the disk to volumes.

■ Mirror the boot (root) disk to provide an alternate boot disk.

These tasks are described in Chapter 3.

▼ To set up volumes & file systems
■ Create volumes.

■ Place file systems on volumes (optional).
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■ Create mirrors for any volumes that need to be redundant.

These tasks are described in Chapter 4.

Maintenance Tasks
After you have set up your disks and volumes, you may need to perform some or all
of the following maintenance tasks.

▼ To maintain disks
■ Place more disks under Volume Manager control, as necessary.

■ Create more disk groups, as necessary.

These tasks are described in Chapter 3.

▼ To maintain volumes
■ Increase the size of volumes as users require more space.

■ Add mirrors to any unmirrored volumes that should be redundant.

■ Create snapshot copies of volumes and then back up the volumes.

■ Reorganize the space occupied by volumes (by moving subdisks to other disks), if
necessary.

These tasks are described in Chapter 4.

▼ To maintain file systems
■ Place additional file systems on volumes, as necessary.

■ Increase the size of file systems as users require more space.

■ Create snapshot copies of vxfs  file systems and then back up the file systems.

These tasks are described in Chapter 4.

Repair/Recovery Tasks
If disk and/or system failures occur, the Volume Manager may perform any
necessary recovery operations automatically. However, depending on the
circumstances, you may need to attempt to recover from the situation as follows.

▼ To protect volumes from disk failure
■ Evacuate a failing disk.
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■ Replace a failed disk.

These tasks are described in Chapter 3.

▼ To repair/recover volumes
■ Recover a volume.

■ Recover all volumes on a failed disk.

■ Recover all volumes in a disk group.

■ If a volume is not recoverable, restore the volume from backup.

These tasks are described in Chapter 3 and Chapter 4.

▼ To repair/recover file systems
■ Perform a file system consistency check on any file systems that may be damaged.

These tasks are described in Chapter 4.

Storage Administrator Icons
The following table shows icons that appear in the Storage Administrator.

Icon Description

Objects:

disk

free disk

uninitialized disk

disk group
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deported disk group

volume

root/boot volume

RAID-5 volume

plex/mirror

subdisk

controller

disk array

subpath (Dynamic Multipathing)

file system

system/machine

Task Status:

task in progress

successful task

Icon Description
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failed task

Toolbar:

Volume Manager window

Task Request Monitor window

Alert Monitor window

Search window

Miscellaneous:

alert

error

information

question

warning

Command Launcher task

Icon Description
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CHAPTER 2

Getting Started

This chapter describes how to set up and start using the Volume Manager Storage
Administrator. This chapter focuses on how to use the main components of the
Storage Administrator.

The following topics are discussed in this chapter:

■ Installation and Setup

■ Starting the Storage Administrator

■ Selecting Objects

■ Viewing Objects and Object Properties

■ Accessing Tasks

■ Using Dialog Boxes

■ Viewing Commands

■ Setting User Preferences

■ Searching for Objects or Free Space

■ Responding to Alerts

■ Exiting the Storage Administrator
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Installation and Setup
The Sun StorEdge Volume Manager Storage Administrator consists of a server and a
client. You must install and run the Storage Administrator server on a UNIX
machine running the Volume Manager. You can install and run the Storage
Administrator client on any machine that supports the Java Runtime Environment.

Before you can use the Volume Manager Storage Administrator, you need to do the
following:

■ Install the Sun StorEdge Volume Manager on the machine to be administered.
Run vxinstall  to create the rootdg  disk group and initialize at least one disk.

■ Install the Storage Administrator server and client on the machine to be
administered.

■ Set up security to specify which users can run the Storage Administrator
(optional). By default, only root  can run the Storage Administrator.

■ If you plan to run the Storage Administrator client from a Web browser, set up a
HyperText Transfer Protocol (HTTP) server on the machine to be administered.

■ If you plan to run the Storage Administrator client from a machine other than the
machine to be administered, install the Storage Administrator client on the
machine where the client will run.

■ Start the Storage Administrator server on the machine to be administered.

■ Start the Storage Administrator client.

Refer to the Sun StorEdge Volume Manager Installation Guide for details on how to
install the Volume Manager and set up rootdg . Refer to the Sun StorEdge Volume
Manager Storage Administrator Release Notes for details on how to install and set up
the Storage Administrator.



Chapter 2 Getting Started 17

Starting the Storage Administrator
Before you start the Volume Manager Storage Administrator, make sure you have
completed the tasks listed in “Installation and Setup” on page 16.

Note – Only users with appropriate privileges can run the Storage Administrator.
Refer to the Sun StorEdge Volume Manager Storage Administrator Release Notes for
information on Storage Administrator security and access permissions.

You can use the Storage Administrator to administer the local machine or a remote
machine. You can start the Storage Administrator as an application or from a Web
browser, as follows.

▼ Starting the Storage Administrator as an application

UNIX

● To administer the local UNIX machine, type:

vxvm

Make sure that the Session Initiation dialog box (described in “The Session Initiation
Dialog Box” on page 19) contains the local machine name.

● To administer a remote UNIX machine, type:

vxvm machine_name

Make sure that the Session Initiation dialog box (described in “The Session Initiation
Dialog Box” on page 19) contains the remote machine name.

Microsoft Windows NT/Microsoft Windows 95

● To administer a remote UNIX machine, choose Start > Programs >
Sun StorEdge Volume Manager Storage Administrator > Sun StorEdge Volume
Manager Storage Administrator.

Specify the remote machine name in the Session Initiation dialog box (described in
“The Session Initiation Dialog Box” on page 19).
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▼ Starting the Storage Administrator from a Web browser

In order to access the Storage Administrator via a Web browser, you must set up and
run an HTTP server on the machine to be administered. See the Volume Manager
Storage Administrator Release Notes for information on how to set up the HTTP server.

● To access the Storage Administrator from a Web browser, start the browser and
then go to the following location (URL):

http:// machine_name/vxvm/index.html

Click on the Sun StorEdge Volume Manager button in the browser window. Specify
the appropriate machine name in the Session Initiation dialog box (described in “The
Session Initiation Dialog Box” on page 19).

Note – Currently, HotJava and Netscape Navigator™ (with Java Development Kit
support) are the only Web browsers that fully support the Storage Administrator.
You can download HotJava from http://www.javasoft.com ; you can download
Netscape from http://www.netscape.com .
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The Session Initiation Dialog Box
At startup, the Storage Administrator displays the Session Initiation dialog box. To
start the Storage Administrator session, complete this dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok. The
Volume Manager Storage Administrator main window appears.

Note – Entries for your user name and password must exist in the password file or
corresponding NIS (Network Information Name Service) table on the machine to be
administered. Your user name must also be included in the VERITAS group entry
(vrtsadm , by default) in the group file or NIS group table. If the vrtsadm  entry
does not exist, only root  can run the Storage Administrator.

Server Host: Type the name of the machine to be administered. Both the
Volume Manager and the Storage Administrator server must be
running on this machine.

User Name: Type your login name. Only users with appropriate privileges can
run the Storage Administrator.

Password: Type your password.
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Selecting Objects
You can select objects in most Storage Administrator windows in the following
ways:

● To select a single object, click on the object. To deselect the object, click on the
object again.

● To select/deselect multiple objects, hold down the Control key while selecting the
objects. The objects that you select in this way do not have to be adjacent.

● To select a range of adjacent objects, select the first object and then hold down the
Shift key while selecting the last object in the range. You can also select multiple
adjacent objects by pressing and holding the mouse button while dragging the
pointer over the desired objects.

For information on how to select objects from dialog boxes, refer to “Using Dialog
Boxes” on page 31.

Viewing Objects and Object Properties
The Volume Manager Storage Administrator provides three main views of objects
and their properties:

■ Tree and Grid View

The main window’s tree and grid view displays volumes, disks, file systems, and
other objects on the system.

■ Graphical View

The Volume Layout Details window displays a graphical view of a single volume
and its components (mirrors/plexes and subdisks).

■ Object Properties Window

The object Properties window contains detailed information about a specific object.

This section describes how to use the tree/grid view, the graphical view, and the
Properties window to view objects and their properties.
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The Tree and Grid View
The main window’s tree and grid view displays volumes, disks, file systems, and
other objects on the system. The object tree is a hierarchical display of object groups.
The grid is a tabular display of objects and a limited set of properties. The Storage
Administrator constantly monitors objects on the system and makes appropriate
changes to the tree and grid displays. For more information about this view, see the
description of the object tree and grid in Chapter 1.

Figure 2-1 shows how a volume appears in the tree and grid view. The object tree is
in the left pane and the grid is in the right pane.

FIGURE 2-1 Tree/Grid View of Volumes

You can view objects in the tree and grid in the following ways:

● To expand or collapse the hierarchy under a particular object group node in the
tree, click on the plus sign (+) or minus sign (-) icon next to that node.

● To display the objects in an object group, click on the appropriate object group in
the object tree. All objects that belong to the selected object group appear in the
grid.

Examples:

To display all volumes, click on Volumes in the object tree. All volumes on the
system appear in the grid. Each volume is listed with a set of properties.
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To display all volumes in the rootdg  disk group, expand the Disk Groups node (by
clicking +), then expand the rootdg  node and click on the Volumes group under
rootdg . Only volumes in the rootdg  disk group appear in the grid.

● To display the objects in an object group that is listed in the grid, double-click on
the object group in the grid. All objects that belong to the object group appear in
the grid.

Example:

To display the volumes in a disk group listed in the grid, go to the grid and double-
click on the disk group name, then double-click on Volumes. All volumes in the disk
group appear in the grid.

Note that double-clicking on an object that does not contain other objects (children)
displays the object’s Properties window instead of its children.

● To sort the objects in the grid by a specific property, click on the appropriate
property column heading. To reverse the sort order, click on the column heading
again.

Example:

To sort volumes by size, click on the Size column heading in the grid.

● To resize a grid column, place the pointer over the line that divides the column
headings and then press and hold the mouse button to drag the column divider to
the desired position.

● To make a copy of the contents of the grid, choose Window > Copy Main Grid. A
copy of the grid appears in a separate window. The new grid window continues to
display and update the objects that were shown when you created the grid copy.
You can create multiple copies of the grid and use these grid windows to display
different sets of objects. For example, you can display volumes in one grid
window and disks in another.

The Graphical View
The Volume Layout Details window displays a graphical view of the selected
volume’s layout, components, and properties. You can select objects or perform tasks
on objects in the Volume Layout Details window. The Volume Layout Details
window is not dynamic, so the objects displayed in this window are not
automatically updated when the volume’s properties change.

The View menu changes the contents of the Volume Layout Details window. The
Selected menu accesses tasks or properties for an object. Context-sensitive popup
menus are also accessible in this window (by right-clicking on an object).
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Figure 2-2 shows how a volume appears in the graphical view.

FIGURE 2-2 Volume Layout Details Window

You can view objects in the graphical view in the following ways:

● To display the Volume Layout Details window for a volume, click on the volume
(in the main window grid) and then choose Volumes > Show Layout.

● To update (refresh) the graphical view to show any recent changes to the current
volume, choose View > Update. The Volume Layout Details window does not
update object properties automatically.
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● To view a different volume, choose View > Open and then specify another volume
in the Open Volume dialog box.

● To hide the detailed information within each object, choose View > Compress
Display. To show details for a particular object in the compressed display, click on
that object.

● To highlight objects that are related to or part of a specific object, choose View >
Projection on Selection and then click on an object. To highlight any subdisks on
the same disk a specific subdisk, choose View >
Subdisk Projection and then click on a subdisk.
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The Object Properties Window
The object Properties window contains detailed information about the selected
object. Some object properties can be changed through the object’s Properties
window. The Properties window contains a set of tabbed pages, each of which
contains information about the object and related objects. The tab labels and page
contents vary, depending on the type of object selected. You can display a different
page by clicking on the tab label.

Figure 2-3 shows how a volume appears in the Volume Properties window.

FIGURE 2-3 Volume Properties Window

You can view object properties in the following ways:

● To view the properties of an object, click on the object (in the main window grid)
and then choose Properties from the Selected menu. You can also access the
Properties window by double-clicking on the object.

Example:

To display volume properties, either click on a volume and then choose Volumes >
Properties or double-click on a volume.
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Note that double-clicking on an object that has children displays the object’s
children instead of the Properties window.

● To change any of the editable items in the Properties window, make the
appropriate changes and then click Ok. This changes the settings for all
properties tabs in the Properties window.

● To update the contents of the Properties window to reflect current properties for
the object, click Refresh.
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Accessing Tasks
Most Volume Manager Storage Administrator tasks are performed by selecting
objects and/or tasks and then completing the resulting dialog boxes. With the
Storage Administrator, you can access tasks from the following:

■ the menu bar

■ a context-sensitive popup menu

■ the Command Launcher

This section describes how to run tasks from menus and the Command Launcher.

Running Tasks From the Menu Bar
You can launch tasks from the Create and Selected menus in the menu bar. The
Create menu creates new Volume Manager objects (volumes and disk groups) and
file systems. The context-sensitive Selected menu launches tasks on a selected object.
The Selected menu is dynamic and changes its name and options based on the type
of object that is selected in the tree or grid. Figure 2-4 shows how the Selected menu
changes when a volume is selected.

FIGURE 2-4 Menu Bar With Selected/Volumes Menu

● To create a new object, choose the type of object to be created from the Create
menu. This launches a dialog box.

Example:

To create a volume, choose Create > Volume. Complete the Create Volume dialog
box, then click Ok.
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● To perform a task on an object with the Selected menu, select the object and
choose the appropriate task from the Selected menu. If this launches a dialog box,
complete the dialog box.

Example:

To change a volume’s name, select the volume in the grid. The Selected menu
becomes the Volumes menu. Choose Volumes > Rename. Type the volume’s new
name in the Rename Volume dialog box, then click Ok.

Running Tasks From a Popup Menu
A context-sensitive popup menu launches tasks on the selected object. Popup menus
do not contain all of the tasks that can be applied to the selected object; additional
tasks are available through the menu bar or the Command Launcher.

FIGURE 2-5 Context-Sensitive Popup Menu

● To perform a task on an object with the popup menu, right-click on the object and
choose the appropriate task in the popup menu. If this launches a dialog box,
complete the dialog box.
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Running Tasks From the Command Launcher
The Command Launcher window launches tasks from a list of objects and associated
Volume Manager Storage Administrator tasks. The Command Launcher lists each
task with an object type and a task description.

The Command Launcher can be displayed as part of the main window (docked) or
as a separate window. The Command Launcher can also be hidden. When the
Command Launcher is attached to the main window, tasks are context sensitive.
However, tasks are not context sensitive when the Command Launcher is separated
from the main window.

The View menu attaches (docks) the Command Launcher to the main window and
closes the Command Launcher window.

FIGURE 2-6 The Command Launcher

● To display the Command Launcher, choose Window > Command Launcher. To
hide the Command Launcher, choose Window > Command Launcher again. You
can also show or hide the Command Launcher by choosing Options > Preferences
> Main Window and clicking Show Command Launcher.

● To perform a task on a specific type of object, select the appropriate
object-task combination from the Command Launcher list.

Example:

To create a volume, choose Volume Create from the Command Launcher. Complete
the Create Volume dialog box.

● To separate or attach (dock) the Command Launcher and the main window, choose
Options > Preferences > Main Window and click Dock Command Launcher.
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● To sort the items listed in the Command Launcher by object type, command, or
task description, click on the appropriate column heading.
To reverse the sort order in a column, click on the column heading again.

● To adjust the height of the Command Launcher when it is attached to the main
window, choose Options > Preferences > Main Window and specify the new
height (in pixels) in the Docked Command Launcher Height field.
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Using Dialog Boxes
The Volume Manager Storage Administrator uses dialog boxes to communicate with
the administrator. Administrators typically use dialog boxes to submit tasks or other
requests. Dialog boxes can contain selectable buttons and/or fields that accept
information. Some dialog box fields contain default values that can be changed.
Items that are not applicable are greyed out.

● To use a dialog box, select the appropriate items and/or type the appropriate
information and then click one of the following buttons to initiate or cancel the
task/request:

Specifying Objects in Dialog Boxes
Most Storage Administrator dialog boxes contain one or more object name fields. If
you select an object before you select the task, the resulting dialog box may include
the selected object’s name. If the object name field is empty, you can specify an object
in one of these ways:

■ Type the object’s name.

■ Click the Browse button next to the object name field and then select the object
from the resulting browse dialog box. Most browse dialog boxes consist of a tree
(left pane) and grid (right pane). To select an object in a browse dialog box, click
on the appropriate object group in the tree and then click on the desired object in
the grid. Figure 2-7 shows a sample browse dialog box.

Ok Perform the current task/request and close the dialog box.

Apply Perform the current task/request and continue to display the dialog
box.

Cancel Close the dialog box and cancel the current task/request.
(If you have already clicked Apply, this does not cancel the task that is
in progress.)
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FIGURE 2-7 Browse Dialog Box

In some cases, you can specify multiple objects (separated by white space) in a single
field. To select multiple objects from a browse dialog box, hold down the Control or
Shift key and click on each object.

You can specify the object’s disk group by preceding the object name with the disk
group name (diskgroup_name/ object_name). The disk group name is required if there
are multiple objects with the same name (in different disk groups) on the system.

Disks in disk groups have two names:

device name The physical disk device name (or disk access name).

disk name The Volume Manager disk name (or disk media name). This is the
logical name given to the disk by the Volume Manager or the
administrator.

Some dialog box fields require the device name and others require the Volume
Manager disk name. In some cases, you can precede the Volume Manager disk name
with an exclamation mark (!disk name) to specify any disk other than that disk.

Specifying Object Sizes in Dialog Boxes

When you type the size of an object in an input field, you can specify sectors,
kilobytes, megabytes, or gigabytes by appending an s , k , m, or g to the size. If you
do not specify a size unit, the size defaults to sectors.
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Viewing Commands
The Volume Manager Storage Administrator logs all user requests performed by the
Storage Administrator. You can view the Storage Administrator task history in either
of these locations:

■ The Task Request Monitor Window

■ The Command Log File

This section describes how to use the Task Request Monitor window and the
command log file to view information about completed tasks and tasks in progress.

The Task Request Monitor Window
The Task Request Monitor window displays a history of tasks performed in the
current session (and any other sessions running on the machine). Each task is listed
with properties such as the user who performed the task, the task status, and the
start/finish times.

The View menu removes finished tasks and closes the window. The Tasks menu
accesses task properties. Context-sensitive popup menus are also accessible in the
Task Request Monitor window (by right-clicking on a task).



34 Sun StorEdge Volume Manager Storage Administrator 1.0 User’s Guide • July 1998

FIGURE 2-8 Task Request Monitor

● To display the Task Request Monitor, click on the Task button (in the toolbar) or
choose Window > Request Monitor from the main window.

● To sort the tasks by task type, click on the Task heading. To sort the tasks by
property, click on the appropriate property column heading. To reverse the sort
order, click on the column heading again.

● To view task properties and the low-level command(s) used to perform a task,
click on the task and choose Tasks > Properties. You can also access task
properties by double-clicking on the task.

The Task Properties window shows the Volume Manager and other commands that
the Storage Administrator used to perform a given task. You can copy commands
from the Executed Commands field to the command line or a script file. For failed
tasks, the Task Properties window includes any relevant error messages.
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FIGURE 2-9 Task Properties Window

The Command Log File
The command log file contains a history of Volume Manager Storage Administrator
tasks performed in the current session and previous sessions. By default, the
command log is located in /var/opt/vmsa/logs/command  on the server. The
command log file contains a description of each task, along with properties such as
the user who performed the task, the task status, the start/finish times, and the low-
level commands used to perform the task. For failed tasks, the command log
includes any relevant error messages.

The following example shows some sample command log file entries:

Create Volume

Description: Create Volume

User: root

Start Date: Thu Feb 26 14:58:55 PST 1998

Finish Date: Thu Feb 26 14:58:56 PST 1998
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State: Successful

Executed Commands:

        /usr/sbin/vxassist -g testdg make vol04 3g layout=nostripe

Create Volume  FAILED!

Description: Create Volume

User: root

Start Date: Thu Feb 26 15:00:12 PST 1998

Finish Date: Thu Feb 26 15:00:14 PST 1998

State: Failed

Executed Commands:

        /usr/sbin/vxassist -g testdg make vol05 5g layout=nostripe

Failed Command: /usr/sbin/vxassist -g testdg make vol05 5g
layout=nostripe

Error Message: vxvm:vxassist: ERROR: Cannot allocate space for
10485760 block volume
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Setting User Preferences
You can change the way items appear in the main window and other Storage
Administrator windows. This section describes how to use the Preferences window
and preference shortcuts to customize the way the Storage Administrator appears.

The Preferences Window
The Preferences window allows you to specify your preferences for how you would
like to view the components of the Storage Administrator. The Preferences window
contains a set of tabbed pages, each of which contains preference options for a
particular aspect of the Storage Administrator. You can display a different page by
clicking on the tab label.

FIGURE 2-10 Preferences Window
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● To display the Preferences window, choose Options > Preferences from the main
window menu bar.

● To change preference settings, make the appropriate selections in the Preferences
window, then click Ok. This changes the settings for all tabs in the Preferences
window. To reset the settings to the previous settings, click Reset (before you click
Ok).

● To save your preferences for future Storage Administrator sessions, choose
Options > Save Preferences. The Storage Administrator saves user preferences in
/var/opt/vmsa/ user_name/preferences , by default.

● To reload your previously saved preferences, choose Options > Load Preferences.

The Preferences window contains the following preference tabs:

■ General

■ Main Window

■ Font

■ Color

■ Geometry

■ Tree/Grid

■ Toolbar

■ Layout Details

The following sections summarize the preference settings available in each of these
tabs.
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General

Set the following general preferences:

Select Text in Field on Enter Set user input to replace mode. This highlights any
existing text in a field and replaces that text with the
new text.

Show Confirmation Dialogs Show/hide confirmation dialogs for tasks that may have
serious consequences (such as data loss). Confirmation
dialogs require users to confirm that a task should be
performed. Confirmation dialogs typically appear for
tasks that remove objects.

Note: If you hide confirmation dialogs, most tasks are
performed immediately and without any form of
confirmation.

Auto-Save Preferences on
Exit

Save all current user preferences when the user exits the
Storage Administrator.

Flush Images Draw images slightly slower than usual to prevent the X
server from growing. This is recommended if you plan
to leave the Storage Administrator running for long
periods of time.

Default Display Unit Set the default size unit for areas that display object
sizes. If Best Choice is set, the Storage Administrator
uses an appropriate size unit.

Summary Decimal Precision Set the decimal point precision for object sizes displayed
in the grid and other areas that display summaries.

Task Decimal Precision Set the decimal point precision for object sizes displayed
in task-related dialog boxes and areas that display
detailed information.
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Main Window

Set the following preferences for the main window:

Font

Set the font size, family, and style for the following:

● To access the Font Selector, click Change. Change the font size by sliding the Size
slider. Use the Family and Style menu to change the font family and style.

Show Status Bar Show/hide the status bar area (at the top of the main
window). The status bar displays alert icons when
failures or errors occur.

Show Message Area Show/hide the message area (at the bottom of the main
window).

Show Command Launcher Show/hide the Command Launcher. The Command
Launcher contains a list of selectable tasks.

Dock Command Launcher Attach/detach the Command Launcher and the main
window.

Docked Command Launcher
Height

Set the height of the Command Launcher portion of the
main window.

User Font Set the font for user input and objects displayed in the
tree and grid.

System Font Set the font for labels, menus, buttons, and other items
displayed by the Storage Administrator.

Grid Heading Font Set the font for grid headings.

Grid Heading Highlight
Font

Set the font for grid headings that are highlighted for
sorting purposes.

Graphical Display Font Set the font for objects in the Volume Layout Details
window.
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Color

Set the following preferences for colors:

● To access the Color Selector, click Change. Change colors by clicking on a color in
the color wheel or sliding the Red, Green, Blue, and Brightness sliders to the
appropriate positions.

Background Color Set the background color for all Storage Administrator
windows.

Foreground Color Set the color for foreground text in Storage
Administrator windows.

Tree/Grid Color Set the background color for the tree and grid.

Connecting Line Color Set the color for the lines that connect items in the tree.

Selection Color Set the color for selected items.

Selection Foreground Color Set the color for foreground text in selected items.

Link Color Set the color for links (such as the links to tasks in the
Command Launcher).

Projection Color Set the color for the lines that show object relationships
in the Volume Layout Details window.
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Geometry

Set the width and height (in pixels) for the following windows:

■ Main Window

■ Object Search Window

■ Alert Monitor Window

■ Task Request Monitor Window

■ Volume Layout Details Window

■ Command Launcher Window

■ Grid Copy Window

If you resize one of these windows via your window manager, the Geometry
preference for that window changes to the new size automatically.

Tree/Grid

Set the following tree and grid preferences:

Toolbar

Set the following preferences for the toolbar:

Display Full Path Display path information in the tree and grid.

Splitter Position Move the splitter to adjust the relative sizes of the tree
and grid panes.

Selector Tree/Grid Width Set the width (in pixels) of the tree and grid in browse
dialog boxes that contain a tree and a grid.

Selector Grid Width Set the width (in pixels) of the grid in browse dialog
boxes that contain a grid only.

Visible Selector Rows Set the number of rows displayed in the tree and grid in
browse dialog boxes.

Show Toolbar Show/hide the toolbar.
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Layout Details

Set the following preferences for the Volume Layout Details window:

Dock Toolbar Attach/detach the toolbar and the main window.

Position Place the docked toolbar at the side or top of the main
window.

Presentation Display icons and/or labels on the buttons in the
toolbar.

Compress Display Compress the graphical display of objects so that details
are hidden.

Projection on Selection When an object is selected, highlight objects that are
related to or part of that object.

Subdisk Projection When a subdisk is selected, highlight other subdisks on
the same disk.
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Preference Shortcuts
● To resize the left (tree) and right (grid) panes, place the pointer over the splitter

and then press and hold the mouse button to drag the splitter to the desired
position.

● To resize a grid column, place the pointer over the line that divides the column
headings and then press and hold the mouse button to drag the column divider to
the desired position. The column widths cannot be saved with other user
preferences.

● To sort the objects in a grid column, click on the column heading of the object
property to be sorted. To reverse the order of the objects, click on the column
heading again. The sort order cannot be saved with other user preferences.

● To acknowledge and clear an alert icon displayed in the status area, choose
Options > Clear Alert Status.



Chapter 2 Getting Started 45

Searching for Objects or Free Space
The Search window searches the system for objects that match the specified search
criteria. The Search window contains a set of tabbed pages, each of which contains
search options for a particular type of object. You can display a different page by
clicking on the tab label.

Any objects that match the search criteria are listed in the lower half of the search
window, along with their properties. Objects displayed in the search window are
monitored and removed from the window if they no longer meet the current search
criteria.

The Search window has menus similar to those in the main menu. Context-sensitive
popup menus are also accessible in the lower half of the Search window (by right-
clicking on an object).

FIGURE 2-11 Object Search Window
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● To display the Search window, click the Search button in the toolbar or choose
Window > Search.

● To begin a search, enter your search criteria and then click Search Now.

Responding to Alerts
When an object fails or experiences an error, an alert icon appears in the status area
of the main window and/or on the object’s icon (see Figure 2-12). If an alert icon
appears, you should review the contents of the Alert Monitor window. The Alert
Monitor window lists information about objects that have failed or experienced
other errors (see Figure 2-13). Each object is listed with a description of the failure or
error.

The Alert menu accesses properties for objects with alerts and closes the window.
Context-sensitive popup menus are also accessible in the Alert Monitor window (by
right-clicking on an object).

After reviewing the alert(s) in the Alert Monitor window, you should try to correct
the problem. For more information about an object listed in the Alert Monitor
window, go to the object’s Properties window.
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FIGURE 2-12 Alerts for a Volume

FIGURE 2-13 Alert Monitor Window

● To display the Alert Monitor window, click the Alerts button in the toolbar or
choose Window > Alerts. You can also access the Alert Monitor window by
clicking on the alert icon in the status area.

alerts
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● To sort alerts by object or description, click on the appropriate column heading.
To reverse the sort order, click on the column heading again.

● To view the properties of an object with an alert, select the object and choose
Alert > Object Properties. You can also access object properties by double-clicking
on the object.

Exiting the Storage Administrator
● To exit the Volume Manager Storage Administrator client, choose Console > Exit.
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CHAPTER 3

Disk Tasks

This chapter describes how to set up and use disks and disk groups with the Volume
Manager Storage Administrator. The Disk Task Roadmap at the beginning of this
chapter contains a summary of common disk and disk group tasks.

The following disk tasks are discussed in this chapter:

■ Adding a Disk to the Volume Manager

■ Designating a Disk as a Hot-Relocation Spare

■ Renaming a Disk

■ Offlining a Disk

■ Onlining a Disk

■ Mirroring a Disk

■ Evacuating a Disk

■ Replacing a Disk

■ Recovering Volumes on a Disk

■ Removing a Disk

■ Displaying a DMP Node

The following disk group tasks are discussed in this chapter:

■ Creating a Disk Group

■ Renaming a Disk Group

■ Deporting a Disk Group

■ Importing a Disk Group

■ Recovering Volumes in a Disk Group

■ Destroying a Disk Group

■ Moving a Disk Group
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Disk Task Roadmap
The following table provides a summary of common Volume Manager Storage
Administrator disk and disk group tasks.

To do this... Use this procedure...

Disk Setup Tasks:

Place new disk(s) under Volume Manager control Adding a Disk to the Volume Manager

Set up new disk group(s) Creating a Disk Group

Precautionary Tasks:

Add disk(s) as hot-relocation spare(s) Designating a Disk as a Hot-Relocation Spare

Place the root (boot) disk under Volume Manager
control

Adding a Disk to the Volume Manager

Make an alternate boot (root) disk Mirroring a Disk

Maintenance Tasks:

Place additional disks under Volume Manager
control

Adding a Disk to the Volume Manager

Add more disk space to a disk group Adding a Disk to the Volume Manager

Create additional disk groups Creating a Disk Group

Recovery Tasks:

Move volumes off failing disks Evacuating a Disk

Replace failed disk(s) Replacing a Disk

Attempt to recover all volumes on a disk Recovering Volumes on a Disk

Attempt to recover all volumes in a disk group Recovering Volumes in a Disk Group

Other Tasks:
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Adding a Disk to the Volume Manager
New disks must be set up on the system, placed under Volume Manager control, and
added to a disk group before they can be used for volumes. The add disk(s) task
performs all of these tasks to prepare new disks for Volume Manager use. You can
also use this task to place the root disk under Volume Manager control or to add a
disk to a disk group.

▼ To add a disk to the Volume Manager

1. If the disk is brand new, select the system name (at the top of the tree) and choose
System > Scan Disks to set up the disk on the system. This runs the disk setup
commands appropriate for the operating system.

2. Select the uninitialized disk to be placed under Volume Manager control.

3. Choose Disks > Add (menu) or Disk Add (Command Launcher).

4. Complete the Add Disk(s) dialog box as follows:

Change a disk’s name Renaming a Disk

Change a disk group’s name Renaming a Disk Group

Temporarily prevent access to a disk Offlining a Disk

Restore access to an offline disk Onlining a Disk

Temporarily prevent access to a disk group Deporting a Disk Group

Restore access to a deported disk group Importing a Disk Group

Remove a disk from Volume Manager control Removing a Disk

Move a disk group to another system Moving a Disk Group

Destroy a disk group (permanently) Destroying a Disk Group

Disk(s): If the correct disk name is not already displayed in this field,
type the disk’s name or click Browse to select the disk.

To do this... Use this procedure...
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When you have provided all necessary information in the dialog box, click Ok.

5. Indicate whether the disk should be initialized or encapsulated. If you initialize
the disk, any existing data on the disk will be destroyed. If you encapsulate the
disk, any existing data will be preserved in volumes.

6. If you chose to encapsulate the disk, reboot the system.

▼ To place the root disk under Volume Manager control

1. Select the root (boot) disk.

2. Choose Disks > Add (menu) or Disk Add (Command Launcher).

3. Complete the Add Disk(s) dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

4. Indicate that the root disk should be encapsulated. When you encapsulate the
disk, any existing data will be preserved in volumes.

5. Reboot the system.

Add Disk(s) to: Specify where the disk(s) should be placed:
• To add the disk(s) to an existing disk group, select
Existing Disk Group. Type the disk group name in the Disk
Group Name field or click Browse to select a disk group.
• To add the disk(s) to a new disk group, select New Disk
Group. Type the name of the new disk group in the Disk
Group Name field. The new disk group will be created for
the new disk.
• To place the disk(s) in the free disk pool, select Free Disk
Pool. Disks in the free disk pool are under Volume Manager
control, but do not belong to a disk group and cannot be
used to create volumes.

Options: To set up any new disks on the system, click Scan Disks.
This runs the disk setup commands appropriate for the
operating system.

Disk(s): If the correct disk name is not already displayed in this field,
type the root disk’s name or click Browse to select the disk.

Add Disk(s) to: Specify that the root disk should be placed in the root disk
group. Select Existing Disk Group. Type the root disk group
name (rootdg ) in the Disk Group Name field or click
Browse to select rootdg .
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▼ To add a disk to a disk group

1. Go to the free disk pool and select the disk to be added to a disk group.

2. Choose Disks > Add (menu) or Disk Add (Command Launcher).

3. Complete the Add Disk(s) dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Disk(s): If the correct disk name is not already displayed in this field,
type the disk’s name or click Browse to select the disk.

Add Disk(s) to: Specify where the disk(s) should be placed:
• To add the disk(s) to an existing disk group, select
Existing Disk Group. Type the disk group name in the Disk
Group Name field or click Browse to select a disk group.
• To add the disk(s) to a new disk group, select New Disk
Group. Type the name of the new disk group in the Disk
Group Name field. The new disk group will be created for
the new disk.

Notes:

• Disks must be under Volume Manager control and in a disk group before they can be
used to create volumes.
• When a disk is placed under Volume Manager control, the disk is either initialized or
encapsulated. Encapsulation preserves any existing data on the disk in the form of
volumes. Initialization destroys any existing data on the disk. Encapsulation is
recommended for the root/boot disk and any other disks that contain valuable data.
• Disk encapsulation requires a system reboot.
• Disks in the free disk pool need to be added to a disk group before they can be used to
create volumes.
• Disks must be online before they can be added to a disk group or the free disk pool.
• Disks that already belong to a disk group cannot be added to another disk group or
placed in the free disk pool.
• Disks cannot be added to deported disk groups.
• The root disk must be placed in the root disk group (rootdg ). If the root disk is placed
in any other disk group, the root disk cannot be used to boot the system.
• After placing the root disk under Volume Manager control, it is recommended that you
create an alternate boot disk by mirroring the root disk (see “Mirroring a Disk” on
page 57).
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Designating a Disk as a Hot-Relocation
Spare
This procedure adds a disk to the pool of spare disks available to the hot-relocation
feature. If an I/O failure occurs, hot-relocation automatically relocates any
redundant (mirrored or RAID-5) subdisks to spare disks and restores the affected
Volume Manager objects and data. The system administrator is notified of the failure
and relocation details via electronic mail. After successful relocation, you may want
to replace the failed disk (see “Replacing a Disk” on page 58).

▼ To designate a disk as a hot-relocation spare

1. Follow the instructions in “Adding a Disk to the Volume Manager” on page 51” to
place the disk under Volume Manager control.

2. Select the disk to be designated as a hot-relocation spare.

3. Choose Disks > Properties.

4. In the disk properties window, go to the General tab and select Spare. Click Ok.

Renaming a Disk
This procedure changes the Volume Manager name of a disk. The Volume Manager
disk name is the name given to the disk by the administrator or the Volume
Manager. This procedure does not change the physical disk name (device name).

▼ To rename a disk

1. Select the disk to be renamed.

2. Choose Disks > Rename (menu) or Disk Rename (Command Launcher).

Notes:

• Any disk in the same disk group can use the spare disk.
• To make sure that sufficient space is available for relocation, try to provide at least one
hot-relocation spare disk per disk group.
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3. Complete the Rename Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Offlining a Disk
This procedure prevents the Volume Manager from accessing a disk. A disk must be
removed from its disk group before it can be taken offline (see “Removing a Disk”
on page 60). An offline disk remains unavailable until you restore access to the disk
(see “Onlining a Disk” on page 56).

▼ To take a disk offline

1. Select the disk to be taken offline.

2. Choose Disks > Offline (menu) or Disk Offline (Command Launcher).

3. Complete the Offline Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Disk Name: If the correct disk name is not already displayed in this field,
type the disk’s name or click Browse to select the disk.

New Name: Type the new Volume Manager disk name.

Notes:

• The new disk name must be unique within the disk group.
• The disk must be in an imported disk group.

Disk Name: If the correct disk name is not already displayed in this field,
type the disk’s name or click Browse to select the disk.
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Onlining a Disk
This procedure restores access to a disk that has been taken offline. The disk is
placed in the free disk pool and is accessible to the Volume Manager again. After
bringing a disk back online, the disk must be added to a disk group before it can be
used for volumes (see “Adding a Disk to the Volume Manager” on page 51).

▼ To bring a disk online

1. Select the disk to be brought online.

2. Choose Disks > Online (menu) or Disk Online (Command Launcher).

3. Complete the Online Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Notes:

• When a disk is offline, the disk cannot be accessed by the Volume Manager.
• A disk can be taken offline to protect it from unintentional use. Disks should be taken
offline if they are not accessible and attempts to access them may have a negative effect on
the system.
• Only disks that do not belong to a disk group can be taken offline.
• Disks that are in use cannot be taken offline.

Disk Name: If the correct disk name is not already displayed in this field,
type the disk’s name or click Browse to select the disk.

Notes:

• When a disk is brought online, the disk is accessible again.
• Only disks in the offline state can be brought online.
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Mirroring a Disk
This procedure mirrors (copies) all concatenated volumes on a disk onto another
disk and sets up the target disk as a boot disk. This is a convenient way of creating
an alternate boot (root) disk, which can be used to boot the system if the original
boot disk fails. You can use this procedure to mirror any disk that contains
concatenated volumes.

▼ To mirror all concatenated volumes on a disk

1. Select the disk that contains the concatenated volumes to be mirrored onto
another disk.

2. Choose Disks > Mirror (menu) or Disk Mirror (Command Launcher).

3. Complete the Mirror Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Disk Name: If the correct disk name is not already displayed in this field,
type the disk’s name or click Browse to select the disk.

Target Disks: To specify the disk(s) to contain the new mirrors, type the
target disk name or click Browse Disks and complete the
target disk dialog box.

Notes:

• This task is typically used to mirror the contents of the boot disk onto another disk,
which can be used as an alternate boot disk. After mirroring the root and swap volumes
(which must be named rootvol  and swapvol , respectively), this task sets up the target
disk as a boot disk.
• Only concatenated volumes are mirrored onto the other disk. Any RAID-5, striped, or
spanned volumes on the disk are ignored.
• Only disks in the same disk group can be used to create the new mirrors.
• The target disk must contain sufficient space to accommodate the mirror(s).
• A new mirror cannot be created on a disk that already contains a copy of the volume.
• If no disks are assigned, the Volume Manager uses available disk space to create the
mirror(s).
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Evacuating a Disk
This procedure moves the contents of the volumes on a disk to another disk. If a disk
begins to fail, you can attempt to protect/preserve the volumes on that disk by
evacuating the disk. You can also evacuate a disk if you plan to remove the disk or
use the disk elsewhere.

▼ To evacuate a disk

1. Select the disk that contains the objects and data to be moved to another disk.

2. Choose Disks > Evacuate (menu) or Disk Evacuate (Command Launcher).

3. Complete the Evacuate Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Replacing a Disk
This procedure replaces an existing disk with a new physical disk, moves any
volumes to the new disk, and attempts to recover any redundant (mirrored or RAID-
5) volumes on the disk. Non-redundant volumes cannot be recovered and should be

Disk Name: If the correct disk name is not already displayed in this field,
type the disk’s name or click Browse to select the disk.

Target Disks: To specify the disk(s) to which the contents of the evacuated
disk should be moved, type the target disk name or click
Browse Disks and complete the target disk dialog box.

Notes:

• The contents of a disk must be evacuated/moved to other disk(s) in the same disk
group with sufficient free space.
• If no target disk is specified, the Volume Manager will use available disk(s) with
sufficient free space.
• If the disk being evacuated contains part of a mirrored, striped, or RAID-5 volume, the
contents of the disk should not be moved to another disk containing a copy of the
mirrored volume or part of the striped/RAID-5 volume.
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restored from backup, if possible. If the disk being replaced is a boot disk, this
procedure also sets up the new disk as a boot disk. You may need to replace a disk if
the disk fails and/or needs to be removed and repaired.

If you replace a healthy disk, you need to remove the disk from its disk group and
place it in the free disk pool before you replace the disk (see “Removing a Disk” on
page 60). If the disk to be replaced has failed and is disconnected, you do not need to
remove the disk.

▼ To replace a disk

1. Select the disk to be replaced.

2. Choose Disks > Replace (menu) or Disk Replace (Command Launcher).

3. Complete the Replace Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Recovering Volumes on a Disk
This procedure performs any necessary volume recovery operations on the volumes
on a given disk. The recovery operations depend on the types of volumes on the
disk and include starting disabled volumes, resynchronizing mirrors in mirrored
volumes, and resynchronizing parity in RAID-5 volumes. After successful recovery,
the volumes should be available for use again.

New Physical Disk: Type the physical disk name for the new (replacement) disk
or click Browse to select a disk.

Disk Name: If the correct disk name is not already displayed in this field,
type the Volume Manager disk name for the disk to be
replaced or click Browse to select the disk.

Notes:

• The disk to be replaced must be disconnected or removed from its disk group. If the
disk has not failed, it may be necessary to remove the disk from its disk group before you
replace the disk.
• The new disk can be a disk in the free disk pool or an uninitialized disk. If the new disk
is uninitialized, this task places the disk under Volume Manager control.
• The new disk is placed in the old disk’s disk group.
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Alert icons and the Alert Monitor window may provide clues to let you know that
volume recovery is needed.

▼ To recover all volumes on a disk

1. Select the disk containing the volumes to be recovered.

2. Choose Disks > Recover (menu) or Disk Recover (Command Launcher).

3. Complete the Recover Disk dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click Ok.

Removing a Disk
This procedure removes a disk from its disk group and either places the disk in the
free disk pool or removes the disk from Volume Manager control. If the disk is
returned to the free space pool, the disk must be added to a disk group before it can
be used for volumes (see “Adding a Disk to the Volume Manager” on page 51). You
can use this procedure to remove a disk permanently or to prepare a disk for
replacement.

▼ To remove a disk from a disk group or Volume Manager

1. Select the disk to be removed.

2. Choose Disks > Remove (menu) or Disk Remove (Command Launcher).

Disk Name: If the correct disk name is not already displayed in this field,
type the disk’s name or click Browse to select the disk.

Notes:

• In some cases, recovery may not be possible. If the volume recovery fails, you can
attempt to restore the volume from backup.
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3. Complete the Remove Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Displaying a DMP Node
This procedure displays the Dynamic Multipathing node that corresponds to the
selected subpath.

▼ To display a Dynamic Multipathing node

1. Select the system name (at the top of the tree).

Disk(s): If the correct disk name is not already displayed in this field,
type the disk’s name or click Browse to select the disk.

After removing disk: Specify how to handle the disk after removal:
• To remove the disk from its disk group and place it in the
free disk pool, select Return to Free Disk Pool. The disk will
remain under Volume Manager control.
• To remove the disk from Volume Manager control, select
Return to Uninitialized State.

Options: To move the contents of the disk to another disk(s) before
the disk is removed, select Evacuate. Click Target Disks to
specify the disk(s) to which the contents of the disk should
be moved.

Notes:

• When a disk is removed from a disk group or Volume Manager control, the disk cannot
be accessed.
• A disk that is in use (i.e. contains volumes) should not be removed. Removing a disk
with volumes can result in loss of data or data redundancy. If volumes exist on the disk to
be removed, you can select Evacuate to move the volumes to another disk.
• The last disk in a disk group cannot be removed. To remove the last disk in a disk
group, the disk group must be deported or removed. The last disk in the rootdg  disk
group can never be removed.
• Any non-redundant volumes on the removed disk become disabled.
• If the disk contains data and you do not evacuate the disk, the disk removal will cause
the disk to become disconnected. If this happens, you can use the Replace Disk task to fix
the disconnected disk.
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2. Choose System > Get DMP Node.

3. Complete the Get DMP Node dialog box as follows:

4. Click Apply.

The DMP node that corresponds to the selected subpath should appear in the DMP
Node: field.

Creating a Disk Group
This procedure creates an additional disk group. Disks must be placed in disk
groups before they can be used by the Volume Manager. The default disk group
(rootdg ) is usually created during Volume Manager installation and always exists
on a system running the Volume Manager. You can create additional disk groups to
organize your disks into logical sets of disks.

▼ To create a disk group

1. Choose Create > Disk Group (menu) or Disk Group Create (Command Launcher).

2. Complete the Create Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

3. Indicate whether the disk should be initialized or encapsulated. If you initialize
the disk, any existing data on the disk will be destroyed. If you encapsulate the
disk, any existing data will be preserved in volumes.

4. If you chose to encapsulate the disks, reboot the system.

Subpaths: Type the subpath to the DMP node to be displayed or click
Browse to select the subpath.

Disk Group Name: Type the name of the disk group to be created. Click View to
view the names of existing disk groups.

Disk(s): Select the disk(s) to be placed in the new disk group.

Options: To set up any new disks on the system, click Scan Disks.
This runs the disk setup commands appropriate for the
operating system.
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Renaming a Disk Group
This procedure changes the name of an existing disk group. You might rename a
disk group to provide a more appropriate name or avoid a name conflict with a disk
group to be imported.

▼ To rename a disk group

1. Select the disk to be renamed.

2. Choose Disks Groups > Rename (menu) or Disk Group Rename (Command
Launcher).

3. Complete the Rename Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Notes:

• The disk group name must be unique.
• The new disk group must contain at least one disk.
• Only disks that are online and do not belong to a disk group can be used to create a
disk group.
• When a disk is placed under Volume Manager control, the disk is either initialized or
encapsulated. Encapsulation preserves any existing data on the disk in the form of
volumes. Initialization destroys any existing data on the disk. Encapsulation is
recommended for the root/boot disk and any other disks that contain valuable data.

Disk Group Name: If the correct disk group name is not already displayed in
this field, type the disk group’s name or click Browse to
select the disk group.

New Name: Type the new name for the disk group.
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Deporting a Disk Group
This procedure makes a disk group inaccessible. Once deported, a disk group cannot
be used until it is imported. Disks in a deported disk group retain knowledge of the
deported disk group until they are removed or reused (assigned to another disk
group). If a disk group’s name or disks are reused while the disk group is deported,
the deported disk group may not be importable.

You can deport a disk group to make the disk group temporarily unavailable. Since
the last disk in a disk group cannot be removed, deporting a disk group is useful for
freeing the last disk in a disk group for removal and reuse.

▼ To deport a disk group

1. Select the disk group to be deported.

2. Choose Disk Groups > Deport (menu) or Disk Group Deport (Command
Launcher).

3. Complete the Deport Disk Group dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click Ok.

Notes:

• The new disk group name must be unique.
• The rename task deports and reimports the disk group. If volumes in the disk group are
in use, the deport fails and the disk group is not renamed.
• This task updates the file system table file, if necessary.
• If the disk group contains volumes with mounted file systems, you may need to
unmount the file systems.

Disk Group Name: If the correct disk group name is not already displayed in
this field, type the disk group’s name or click Browse to
select the disk group.

Options: Use the following expert options with caution:
• To change the name of the disk group at deport, type a
new disk group name in the New Name field.
• To set up a host machine to import the deported disk
group at reboot, type the host ID in the New Host field.
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Importing a Disk Group
This procedure makes a deported (inaccessible) disk group accessible again. To
import a deported disk group, you must know the disk group’s former name and
this disk group name must remain unused. In addition, at least one disk formerly
assigned to the deported disk group must remain unused.

▼ To import a disk group

1. Select the system name (at the top of the tree).

2. Choose System > Import Disk Group (menu) or Disk Group Import (Command
Launcher).

Notes:

• A deported disk group is inaccessible.
• The rootdg  disk group cannot be deported.
• A disk group cannot be deported if any volumes in that disk group are in use (open).
• When a disk group is deported, the host ID stored on all disks in the disk group is
cleared and the disk group is not reimported automatically when the system is rebooted.
However, if you specify a host in New Host expert option, the specified host will import
the disk group at reboot.



66 Sun StorEdge Volume Manager Storage Administrator 1.0 User’s Guide • July 1998

3. Complete the Import Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Disk Group Name: Type the name of the disk group to be imported or click
Browse to select the disk group.

Options: Use the following expert options with caution:
• To start all volumes in the disk group at import, click Start
All Volumes.
• To clear the existing host ID stamp on all disks in the disk
group at import, click Clear Host ID. Do not use this option
if another host is using any disk(s) in the disk group.
• To force the disk group import when the host cannot
access all disks in the disk group, click Force Import. This
option can be used to import a disk group that contains a
failed disk, but can lead to disk group inconsistency if all
disks are still usable.
• To change the name of the disk group at import, type a
new disk group name in the New Name field. To indicate
that the name change is temporary, click Use New Name as
Temporary.

Notes:

• Only deported disk groups can be imported.
• A deported disk group cannot be imported if another disk group with the same name
has been created since the disk group was deported.
• If all disks associated with a deported disk group have been reused since the disk was
deported, that disk group cannot be imported.
• A disk group import may fail if the host cannot find one or more disks in the disk
group. If the import fails because a disk has failed, you can import the disk group by
clicking the Force Import expert option. If the import fails for another reason, a forced
import can cause serious problems.
• When a disk group is imported, the system stamps its host ID on all disks in the disk
group. A disk group import should fail if one of the disks is stamped with a host ID that
does not match the others. This ensures that dual-ported disks cannot be managed (and
possibly corrupted) by two systems at the same time. If you are sure that the disk group is
not in use by another host, you can clear the host IDs and import the disk group by
clicking the Clear Host ID expert option.
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Recovering Volumes in a Disk Group
This procedure performs any necessary volume recovery operations on the volumes
in a given disk group. The recovery operations depend on the types of volumes in
the disk group and include starting disabled volumes, resynchronizing mirrors in
mirrored volumes, and resynchronizing parity in RAID-5 volumes. After successful
recovery, the volumes should be available for use again.

Alert icons and the Alert Monitor window may provide clues to let you know that
volume recovery is needed.

▼ To recover all volumes in a disk group

1. Select the disk group containing the volumes to be recovered.

2. Choose Disk Groups > Recover (menu) or Disk Group Recover (Command
Launcher).

3. Complete the Recover Disk Group dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click Ok.

Destroying a Disk Group

Caution – Destroying a disk group can result in loss of data.

Disk Group Name: If the correct disk group name is not already displayed in
this field, type the disk group’s name or click Browse to
select the disk.

Notes:

• In some cases, recovery may not be possible. If the volume recovery fails, you can
attempt to restore the volume from backup.
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This procedure permanently removes a disk group from Volume Manager control.
This also reinitializes all of the disks in the disk group as empty disks and places
them in the free disk pool for reuse. This task should be used with caution.

▼ To destroy a disk group

1. Select the system name (at the top of the tree).

2. Choose System > Destroy Disk Group (menu) or Disk Group Destroy (Command
Launcher).

3. Complete the Destroy Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Moving a Disk Group
This procedure moves a disk group (and the Volume Manager objects in that disk
group) from one system to another. This relocates the disk group’s configuration to
the new system.

▼ To move a disk group from one machine to another

1. Unmount and stop all volumes in the disk group to be moved. (See Chapter 4 for
information on how to unmount and stop volumes.)

2. Follow the instructions in “Deporting a Disk Group” on page 64 to deport the
disk group to be moved to the other system.

3. Attach all of the physical disks in the disk group to the new system.

4. On the new system, follow the instructions in “Importing a Disk Group” on
page 65 to import the disk group.

Disk Group Name: Type the name of the disk group to be destroyed or click
Browse to select the disk group.

Notes:

• When a disk group is destroyed, its disk space is returned to the free space pool.
• The rootdg  disk group cannot be destroyed.
• A disk group cannot be destroyed if any volumes in that disk group are in use (open).
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5. Select the system name (at the top of the tree) and choose System > Scan Disks to
set up the newly attached disks on the system. This runs the disk setup
commands appropriate for the operating system.

6. Follow the instructions in “Recovering Volumes in a Disk Group” on page 67 to
restart and recover all volumes in the disk group on the new system.

Notes:

• The Volume Manager and the Storage Administrator (server) must be running on both
systems.
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CHAPTER 4

Volume Tasks

This chapter describes how to create and use volumes with the Volume Manager
Storage Administrator. It also includes information on how to use file systems with
volumes.The Volume Task Roadmap and File System Task Roadmap at the
beginning of this chapter contain summaries of common volume and file system
tasks.

The following volume tasks are discussed in this chapter:

■ Creating a Volume

■ Resizing a Volume

■ Renaming a Volume

■ Adding a Mirror to a Volume

■ Adding a Log to a Volume

■ Stopping a Volume

■ Starting a Volume

■ Creating a Snapshot Copy of a Volume

■ Preparing to Restore a Volume From Backup

■ Recovering a Volume

■ Repairing a Mirror

■ Disabling a Mirror

■ Removing a Mirror From a Volume

■ Removing a Log From a Volume

■ Removing a Volume

■ Moving a Subdisk

■ Splitting a Subdisk

■ Joining Subdisks

The following file system tasks are discussed in this chapter:
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■ Adding a File System to a Volume

■ Mounting a File System on a Volume

■ Resizing a File System

■ Creating a Snapshot Copy of a File System

■ Unmounting a File System on a Volume

■ Checking a File System on a Volume

Volume Task Roadmap
The following table provides a summary of common Volume Manager Storage
Administrator volume tasks.

To do this... Use this procedure...

Volume Setup Tasks:

Create new volume(s) Creating a Volume

Precautionary Tasks:

Mirror (copy) volumes onto other disks for
redundancy

Adding a Mirror to a Volume

Create mirrored volumes Creating a Volume

Add a log to a mirrored volume Adding a Log to a Volume

Add a log to a RAID-5 volume Adding a Log to a Volume

Maintenance Tasks:

Add space to volumes Resizing a Volume

Add mirrors to volumes that should be redundant Adding a Mirror to a Volume

Create a snapshot copy of a volume for backup Creating a Snapshot Copy of a Volume

Move portions of volumes to other disk space Moving a Subdisk
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File System Task Roadmap
The following table provides a summary of common Volume Manager Storage
Administrator file system tasks.

Recovery Tasks:

Attempt to recover a volume Recovering a Volume

Attempt to recover all volumes on a disk Recovering Volumes on a Disk (see Chapter 3))

Attempt to recover all volumes in a disk group Recovering Volumes in a Disk Group (see Chapter 3)

Prepare to restore a volume from backup Preparing to Restore a Volume From Backup

Repair or reattach a volume’s disabled mirror Repairing a Mirror

Other Tasks:

Change a volume’s name Renaming a Volume

Temporarily prevent access to a volume Stopping a Volume

Restore access to a stopped volume Starting a Volume

Temporarily prevent access to a volume’s mirror Disabling a Mirror

Remove a mirror from a volume Removing a Mirror From a Volume

Remove a DRL log from a volume Removing a Log From a Volume

Remove a RAID-5 log from a volume Removing a Log From a Volume

Remove a volume Removing a Volume

To do this... Use this procedure...
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Creating a Volume
The Volume Manager uses logical volumes to organize and manage disk space. A
volume is made up of portions of one or more physical disks, so it does not have the
physical limitations of a physical disk. A volume can contain a file system or a
database.

A volume can provide greater capacity and better availability and performance than
a single physical disk. A volume can be extended (grown) across multiple disks to
increase capacity, mirrored (copied) on another disk to provide data redundancy, or
striped across multiple disks to improve I/O performance.

This section describes how to use the Volume Manager Storage Administrator to
create the following types of volumes:

■ Concatenated Volume

To do this... Use this procedure...

File System Setup Tasks:

Create a volume with a file system Creating a Volume

Place a file system on an existing volume Adding a File System to a Volume

Mount a file system on a volume Mounting a File System on a Volume

Maintenance Tasks:

Add more space to a file system Resizing a File System

Create a snapshot copy of a file system for backup Creating a Snapshot Copy of a File System

Recovery Tasks:

Perform a file system consistency check Checking a File System on a Volume

Other Tasks:

Unmount a file system Unmounting a File System on a Volume
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A concatenated volume is made up of one or more disk regions that are linked
together (concatenated) in a linear fashion. A concatenated volume can consist of
disk regions on multiple disks; a concatenated volume that extends across two or
more disks is also known as a spanned volume.

Note that the data in this type of volume cannot be recovered if the underlying disk
fails. However, a concatenated volume can be mirrored (copied) onto another disk(s)
to protect its data against disk failure.

■ Striped Volume

A striped volume’s data is interleaved (striped) across two or more physical disks. A
striped volume’s data is spread across the disks alternately and evenly in small
portions of data called stripe units. Striping improves performance.

Note that the data in this type of volume cannot be recovered if one of the
underlying disks fails. However, a striped volume can be mirrored (copied) onto
another disk(s) to protect its data against disk failure.

■ RAID-5 Volume

A RAID-5 volume’s data is interleaved (striped) across three or more physical disks.
Within each stripe across the set of disks, the data on one of the disks is parity data.
If one of the physical disks fails, the parity data can be used to reconstruct and
recover the lost data.

Note that RAID-5 volumes cannot be mirrored.

■ Mirrored Volume

Volumes with concatenated or striped layouts can be mirrored. All of the data in a
mirrored volume is duplicated on at least one other physical disk. If one of the disks
fails, the data can still be accessed from one of the remaining disks.

▼ To create a concatenated volume

This procedure creates a concatenated volume that consists of one or more regions of
the specified disk(s). This procedure also gives you the options of placing a file
system on the new volume or mirroring the volume.

1. Choose Create > Volume (menu) or Volume Create (Command Launcher).

2. Complete the Create Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse to select
another disk group.

Volume Name: Type the new volume’s name (or accept the default name).
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When you have provided all necessary information in the dialog box, click Ok.

▼ To create a striped volume

This procedure creates a striped volume that is spread across two or more disks.
This procedure also gives you the options of placing a file system on the new
volume or mirroring the volume.

1. Choose Create > Volume (menu) or Volume Create (Command Launcher).

2. Complete the Create Volume dialog box as follows:

Size: Type the volume size. To specify a size unit, attach an s
(sectors), k  (kilobytes), m (megabytes), or g (gigabytes) to the
size.
To determine the largest possible size for the volume, click
Maxsize.

Layout: Choose Concatenated for the volume layout.

Options: • To mirror the volume, select Mirrored. In the Total
Number of Mirrors field, type the total number of mirrors
for the volume.
• To place the volume on a specific disk, click Assign Disks
and select the disk you want to use from the Space
Allocation - Create Volume dialog box.
• To place a file system on the volume, click Add File
System and specify the file system type and mount point in
the Add File System dialog box.
• To add a comment attribute for the volume, type the
information in the Comment field.

Notes:

• The volume size should be less than or equal to the available free space on the disk(s).
• If no disks are assigned, the Volume Manager uses available space on disks in the
selected disk group.
• The data in a concatenated volume is not protected against disk failure unless the
volume is mirrored. At least one additional disk is required to mirror a concatenated
volume.
• If a file system is placed on the volume and the Mount at Boot option is selected, the
file system table file is automatically updated.

Disk Group Name: Either accept the default disk group or click Browse to select
another disk group.
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When you have provided all necessary information in the dialog box, click Ok.

Volume Name: Type the new volume’s name (or accept the default name).

Size: Type the volume size. To specify a size unit, attach an s
(sectors), k  (kilobytes), m (megabytes), or g (gigabytes) to the
size.
To determine the largest possible size for the volume, click
Maxsize.

Layout: Choose Striped for the volume layout.
In the Number of Columns field, specify the number of
columns (disks) across which the volume should be striped.
A striped volume requires at least two disks.
To specify a stripe unit size other than the default, type the
stripe unit size in the Stripe Unit Size field. To specify a size
unit, attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.

Options: • To mirror the volume, select Mirrored. In the Total
Number of Mirrors field, type the total number of mirrors
for the volume.
• To stripe the volume across specific disks, click Assign
Disks and select the disks you want to use from the Space
Allocation - Create Volume dialog box.
• To place a file system on the volume, click Add File
System and specify the file system type and mount point in
the Add File System dialog box.
• To add a comment attribute for the volume, type the
information in the Comment field.

Notes:

• A striped volume requires at least two disks.
• The volume size should be less than or equal to the available free space on the disk(s).
• If no disks are assigned, the Volume Manager uses available space on disks in the
selected disk group.
• The data in a striped volume is not protected against disk failure unless the volume is
mirrored. At least one additional disk is required to mirror a striped volume.
• If a file system is placed on the volume and the Mount at Boot option is selected, the
file system table file is automatically updated.
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▼ To create a RAID-5 volume

This procedure creates a RAID-5 volume that is spread across two or more disks and
contains parity information. This procedure also gives you the option of placing a
file system on the new volume.

1. Choose Create > Volume (menu) or Volume Create (Command Launcher).

2. Complete the Create Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Disk Group Name: Either accept the default disk group or click Browse to select
another disk group.

Volume Name: Type the new volume’s name (or accept the default name).

Size: Type the volume size in the Size field. To specify a size unit,
attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.
To determine the largest possible size for the volume, click
Maxsize.

Layout: Choose RAID-5 for the volume layout.
In the Number of Columns field, specify the number of
columns (disks) across which the volume should be striped.
A RAID-5 volume requires at least three disks.
To specify a stripe unit size other than the default, type the
stripe unit size in the Stripe Unit Size field. To specify a size
unit, attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.

Options: • To stripe the volume across specific disks, click Assign
Disks and select the disks you want to use from the Space
Allocation - Create Volume dialog box.
• To place a file system on the volume, click Add File
System and specify the file system type and mount point in
the Add File System dialog box.
• To specify the number and size(s) of RAID-5 logs for the
volume, click Log Details. By default, the Volume Manager
will create one RAID-5 log with an appropriate size.
• To add a comment attribute for the volume, type the
information in the Comment field.
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▼ To create a mirrored volume

This procedure creates a concatenated or striped volume that is mirrored (copied) on
at least one other disk. If one of the disks fails, the volume’s data can be accessed
from the surviving disk(s).

1. Choose Create > Volume (menu) or Volume Create (Command Launcher).

2. Complete the Create Volume dialog box as follows:

Notes:

• A RAID-5 volume requires at least three disks.
• RAID-5 volumes cannot be mirrored.
• The volume size should be less than or equal to the available free space on the disk(s).
• For a RAID-5 volume, the size specified in the Size field is the usable space in the
volume. The Volume Manager allocates additional space for the volume’s parity
information. The disks across which the RAID-5 volume will be striped should therefore
contain additional free space for the volume’s parity information.
• If no disks are assigned, the Volume Manager uses available space on disks in the
selected disk group.
• If a file system is placed on the volume and the Mount at Boot option is selected, the
file system table file is automatically updated.
• This task automatically creates a RAID-5 log for the volume. To specify a different
number of logs or no logs, click the Log Details button and complete the Log Details
Dialog box.

Disk Group Name: Either accept the default disk group or click Browse to select
another disk group.

Volume Name: Type the new volume’s name (or accept the default name).

Size: Type the volume size in the Size field. To specify a size unit,
attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.
To determine the largest possible size for the volume, click
Maxsize.
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When you have provided all necessary information in the dialog box, click Ok.

Layout: Choose Concatenated or Striped for the volume layout.
For a striped volume, provide the following information:
In the Number of Columns field, specify the number of
columns (disks) across which the volume should be striped.
A striped volume requires at least two disks.
To specify a stripe unit size other than the default, type the
stripe unit size in the Stripe Unit Size field. To specify a size
unit, attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.

Mirror Info: • Select Mirrored. In the Total Number of Mirrors field, type
the total number of mirrors for the volume.

Options: • To place the volume on a specific disk(s), click Assign
Disks and select the disks you want to use from the Space
Allocation - Create Volume dialog box.
• To place a file system on the volume, click Add File
System and specify the file system type and mount point in
the Add File System dialog box.
• To add a comment attribute for the volume, type the
information in the Comment field.
• To specify the number and size(s) of Dirty Region Logging
(DRL) logs for the volume, click Log Details. By default, the
Volume Manager will create one DRL log with an
appropriate size.

Notes:

• A mirrored volume requires at least two disks.
• Only concatenated or striped volumes can be mirrored.
• This task automatically creates a Dirty Region Logging log for the volume. To specify a
different number of logs or no logs, click the Log Details button and complete the Log
Details Dialog box.
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Resizing a Volume
This procedure changes the size of a volume. If users require more space on a
volume, you can use this procedure to increase the size of the volume. If a volume
contains unused space that you need to use elsewhere, you can use this procedure to
shrink the volume. If the volume contains a file system, this procedure also resizes
the file system.

▼ To resize a volume

1. Select the volume to be resized.

2. Choose Volumes > Resize (menu) or Volume Resize (Command Launcher).

3. Complete the Resize Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Specify one of the following:
• To increase the volume size by a specific amount of space,
use the Add By field to specify how much space should be
added to the volume.
• To decrease the volume size by a specific amount of space,
use the Subtract By field to specify how much space should
be removed from the volume.
• To specify the new volume size, type the size in the
Desired Size field.
To specify a size unit, attach an s  (sectors), k  (kilobytes), m
(megabytes), or g (gigabytes) to the size.

Notes:

• A volume containing a ufs  file system cannot be shrunk.
• A volume containing an unmounted vxfs  file system cannot be shrunk. Shrinking a
volume with an unmounted file system can result in data loss.
• When the volume size is increased, sufficient disk space must be available. When
increasing the size of a volume, the Volume Manager assigns the necessary new space
from available disks.
• When a volume is shrunk, the resulting extra space is returned to the free space pool.



82 Sun StorEdge Volume Manager Storage Administrator 1.0 User’s Guide • July 1998

Renaming a Volume
This procedure changes the name of a volume. If the volume has a file system, this
procedure also makes the necessary changes to the file system table file and allows
you to specify a new mount point for the file system.

▼ To rename a volume

1. Select the volume to be renamed.

2. Choose Volumes > Rename (menu) or Volume Rename (Command Launcher).

3. Complete the Rename Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Adding a Mirror to a Volume
This procedure creates a mirror (copy) of a volume on a disk that is not already
being used by the volume. If one of the disks fails, the volume’s data can be accessed
from the surviving disk(s). A volume can have multiple mirrors.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

New Name: Type the new name for the volume.

Options: If the volume contains a file system and you want to change
the mount point when the volume is renamed, type a new
mount point in the New Mount Point field.

Notes:

• The new volume name must be unique within the disk group.
• If the volume contains a file system, the file system table file is automatically updated
(if necessary).
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▼ To add a mirror to an existing volume

1. Select the volume to be mirrored.

2. Choose Volumes > Mirror > Add (menu) or Volume Add Mirror (Command
Launcher).

3. Complete the Add Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.
Adding a mirror requires resynchronization, so this task may take some time.

Adding a Log to a Volume
This procedure adds the appropriate type of log to a mirrored or RAID-5 volume.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Options: • To specify the layout for the mirror, click Layout and
complete the Mirror Layout Details dialog box.
• To place the mirror on a specific disk(s), click Assign
Disks and select the disks you want to use.

Notes:

• Once mirrored, the data in the volume is redundant. If a disk fails, the data will remain
available on the surviving mirror (on another disk).
• Only disks in the same disk group as the volume can be used to create the new mirror.
• The new mirror must have a concatenated or striped layout.
• A RAID-5 volume cannot be mirrored.
• The new mirror cannot be created on a disk that already contains a copy of the volume.
• If no disks are assigned, the Volume Manager uses available disk space to create the
mirror.
• The number of available disks must be sufficient to accommodate the layout type of the
mirror(s).
• To mirror the root volume (and other volumes required to boot the system) onto an
alternate boot disk, use the Mirror Disk task.
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▼ To add a DRL log to a mirrored volume

This procedure adds a Dirty Region Logging (DRL) log to a mirrored volume. DRL
uses this log to track the regions of the volume that change due to I/O writes. If a
system failure occurs, DRL uses the information in the log to recover only the
portions of the volume that need recovery. This speeds up recovery time for
mirrored volumes.

For DRL to be in effect, a mirrored volume must have at least one DRL log. You can
create additional DRL logs (on different disks) to mirror the DRL information.

1. Select the mirrored volume to contain the log.

2. Choose Volumes > Log > Add (menu) or Volume Add Log (Command Launcher).

3. Complete the Add Log dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

▼ To add a log to a RAID-5 volume

This procedure adds a log to a RAID-5 volume. RAID-5 logs speed up the
resynchronization time for RAID-5 volumes after a system failure. A RAID-5 log
maintains a copy of the data and parity being written to the volume at any given
time. If a system failure occurs, the Volume Manager can “replay” the RAID-5 log to
resynchronize the volume. This copies the data and parity that was being written at
the time of failure from the log to the appropriate areas of the RAID-5 volume.

You can create multiple RAID-5 logs (on different disks) to mirror the log
information. Ideally, each RAID-5 volume should have at least two logs.

1. Select the RAID-5 volume to contain the log.

2. Choose Volumes > Log > Add (menu) or Volume Add Log (Command Launcher).

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Disk: To place the log on a specific disk, type the name of the disk
or click Browse Disks to select a disk.

Notes:

• When a log is added to a mirrored volume, dirty region logging is activated for that
volume.
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3. Complete the Add Log dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Stopping a Volume
This procedure disables a volume. When a volume is stopped, it is not available for
use until it is restarted (refer to “Starting a Volume” on page 86). Stopping a volume
is a safe way of temporarily preventing access to a volume.

▼ To stop a volume

1. Select the volume to be stopped.

2. Choose Volumes > Stop (menu) or Volume Stop (Command Launcher).

3. Complete the Stop Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

The volume’s state should change to Stopped.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Disk: To place the log on a specific disk, type the name of the disk
or click Browse Disks to select a disk.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Notes:

• A volume cannot be stopped if it is in use (open) or it has a mounted file system.
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Starting a Volume
This procedure attempts to enable (start) a stopped volume. When a volume is
successfully restarted, the volume is available for use again. This procedure also
performs any appropriate resynchronization operations on the volume.

Under normal circumstances, volumes are automatically started when the system
reboots. You can use this procedure to restart a volume that you stopped manually
or to attempt to restart a volume that was stopped in some other manner. If a
volume cannot be started, the volume remains unusable.

▼ To start a volume

1. Select the (stopped) volume to be started.

2. Choose Volumes > Start (menu) or Volume Start (Command Launcher).

3. Complete the Start Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

The volume’s state should change to Started.

Creating a Snapshot Copy of a Volume
This procedure prepares a volume for backup by creating a new volume that is a
snapshot copy of an existing volume. This is done by attaching a new mirror to the
existing volume, copying the volume’s data to the new mirror, detaching the new
mirror, and then creating a new (snapshot) volume from the new mirror. The

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Notes:

• Starting a RAID-5 volume enables the volume and resynchronizes parity, if necessary.
• Starting a mirrored volume enables the volume and resynchronizes the mirrors to
ensure that they are consistent.
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snapshot volume is an exact copy of the original volume. You can use the snapshot
volume to make a backup of the original volume at a convenient time. After the
backup is made, you can remove the snapshot volume (see “Removing a Volume” on
page 93).

▼ To create a snapshot copy of a volume’s data

1. Select the volume to be copied to a snapshot.

2. Choose Volumes > Snapshot (menu) or Volume Snapshot (Command Launcher).

3. Complete the Volume Snapshot dialog box as follows:

4. When you have provided all necessary information in the dialog box, click
Snapstart to start the first phase of the snapshot procedure. This creates a snapshot
mirror of the volume to be backed up. This may take some time.

5. When a Click Snapshot to create the snapshot volume  message appears at
the bottom of the dialog box, click Snapshot to complete the snapshot. This
creates a snapshot copy of the original volume.

If you decide not to make a snapshot volume, you can remove the snapshot mirror
after the snapstart phase. To remove the snapshot mirror, click Remove Snapshot
Mirror.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Snapshot Name: Type the name for the snapshot copy of the volume.

Options: To place the snapshot on a specific disk(s), click Assign
Disks and select the disks you want to use.

Notes:

• The snapshot volume is an exact copy of the original volume at the time the snapshot
phase of the procedure starts.
• After you create the snapshot copy of the volume, remember to back it up to tape or
some other media. Remove the snapshot volume when it is no longer needed.
• The snapstart phase of this task may take a long time, depending on the size of the
volume.
• If you remove the snapshot mirror, you cannot create a snapshot volume until you
repeat the snapstart phase of the procedure.
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Preparing to Restore a Volume From
Backup
This procedure stops and reinitializes a volume so that the volume can be reloaded
from backup. This may be necessary if a volume’s mirrors become unsynchronized.

▼ To prepare a volume for a restore from backup

1. Select the volume to be restored from backup.

2. Choose Volumes > Prepare for Restore (menu) or Volume Prep Restore (Command
Launcher).

3. Complete the Prepare Volume For Restore dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click Ok.

When you have completed this task, you can restore the volume’s data from backup.

Recovering a Volume
This procedure performs any necessary volume recovery operations on a volume.
The recovery operations depend on the type of volume and include starting disabled
volumes, resynchronizing mirrors in mirrored volumes, and resynchronizing parity
in RAID-5 volumes. After successful recovery, the volume should be available for
use again.

Alert icons and the Alert Monitor window may provide clues to let you know that
volume recovery is needed.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Notes:

• If the volume contains a mounted file system, the file system must be unmounted
before this task can proceed. This task does not remount the file system.
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▼ To recover a failed volume

1. Select the volume to be recovered.

2. Choose Volumes > Recover (menu) or Volume Recover (Command Launcher).

3. Complete the Recover Volume dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click Ok.

Repairing a Mirror
This procedure repairs a disabled mirror by reattaching the mirror to its volume.
This involves copying data from an active mirror on the volume to the mirror being
attached. Once attached, the mirror is accessible for reads and writes again.

Alert icons and the Alert Monitor window may provide clues to let you know that a
mirror needs to be repaired.

▼ To repair a mirror

1. Select the volume that contains the mirror to be repaired.

2. Choose Volumes > Mirror > Repair (menu) or Mirror Repair (Command
Launcher).

3. Complete the Repair Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Notes:

• In some cases, recovery may not be possible. If the volume recovery fails, you can
attempt to restore the volume from backup.

Select the mirror to
repair:

Select the mirror to be repaired.
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Disabling a Mirror

Note – Disabling a mirror can result in loss of data redundancy.

This procedure disables a mirror by temporarily detaching the mirror from its
volume. A detached mirror is inaccessible for reads and writes, but is still associated
with its volume. Once disabled, the mirror remains detached from its volume until
you either reattach the mirror (refer to “Repairing a Mirror” on page 89) or restart
the volume.

▼ To disable a mirror in a volume

1. Select the volume that contains the mirror to be disabled.

2. Choose Volumes > Mirror > Disable (menu) or Mirror Disable (Command
Launcher).

3. Complete the Disable Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Notes:

• This task recovers the mirror so that it has the same contents as other mirrors in the
volume.
• Depending on the amount of data in the volume, this task may take some time.

Select the mirror to
disable:

Select the mirror to be disabled.
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Removing a Mirror From a Volume

Note – Removing a mirror can result in loss of data redundancy.

This procedure removes a mirror from its volume. This breaks the link between the
mirror and its volume and returns the mirror’s disk space to the free space pool for
reuse. You can remove an extra mirror from a volume to make the underlying disk
space available for use elsewhere. However, this may leave the volume unmirrored
and unprotected against disk failure.

▼ To remove a mirror from a volume

1. Select the volume that contains the mirror to be removed.

2. Choose Volumes > Mirror > Remove (menu) or Mirror Remove (Command
Launcher).

3. Complete the Remove Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Notes:

• When a mirror is disabled, volume reads and writes cannot be directed to the mirror.
• If a volume only has two mirrors and one mirror is disabled, the volume is not
redundant while the mirror is disabled.
• The last mirror in a volume cannot be disabled.
• When a volume is restarted, any disabled (detached) mirrors should be reattached to
the volume automatically.

Select the mirror to
remove:

Select the mirror to be removed.
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Removing a Log From a Volume
This procedure removes a log from a mirrored or RAID-5 volume. For a mirrored
volume, this removes a DRL log from the volume. For a RAID-5 volume, this
removes a RAID-5 log from the volume.

▼ To remove a log from a volume

1. Select the volume that contains the RAID-5 or DRL log to be removed.

2. Choose Volumes > Log > Remove (menu) or Log Remove (Command Launcher).

3. Complete the Remove Log dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Notes:

• If a volume only has two mirrors and one mirror is removed, the volume is no longer
redundant.
• The last mirror (plex) cannot be removed from a volume.
• When a mirror is removed, the space occupied by that mirror is returned to the free
space pool.

Select the log to
remove:

Select the log to be removed.

Notes:

• If the only log is removed from a volume, logging (either dirty region logging or RAID-
5 logging) is no longer in effect for that volume. When logging is disabled, recovery time
increases.
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Removing a Volume

Caution – Removing a volume can result in data loss.

This procedure permanently removes a volume and all of its data. You should only
remove a volume if you are sure that you do not need the data in the volume (or the
data is backed up elsewhere). You can remove a volume to make the underlying disk
space available for use elsewhere.

▼ To remove a volume

1. Select the volume to be removed.

2. Choose Volumes > Remove (menu) or Volume Remove (Command Launcher).

3. Complete the Remove Volume dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click Ok.

Moving a Subdisk
This procedure moves the contents of a volume’s subdisk from one disk to another.
This is useful for moving portions of a volume to a different disk for improved
performance.

▼ To move a subdisk to another disk

1. Select the volume with the subdisk to be moved.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Notes:

• Removing a volume destroys all of the data in that volume.
• When a volume is removed, the space it occupied is returned to the free space pool.
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2. Choose Show Layout.

3. In the Volume Layout Details window, select the subdisk to be moved to another
disk.

4. Choose Subdisks > Move (menu) or Subdisk Move (Command Launcher).

5. Complete the Move Subdisk dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Splitting a Subdisk
This procedure divides a subdisk into two or more smaller subdisks. Once split, the
smaller subdisks can be moved elsewhere or rejoined later. This is useful for
reorganizing volumes and/or improving performance.

▼ To split a subdisk into multiple subdisks

1. Select the volume with the subdisk to be split.

2. Choose Show Layout.

3. In the Volume Layout Details window, select the subdisk to be split into multiple
subdisks.

Disk Group Name: The name of the disk group that contains the subdisk to be
moved.

Source Subdisk: If the correct subdisk name is not already displayed in this
field, type the subdisk’s name or click Browse to select the
subdisk.

Target Disk: Type the name of the disk to which the subdisk should be
moved or click Browse to select a disk.

Notes:

• Subdisks are typically moved to reorganize disk space.
• The disk space occupied by the original subdisk is returned to the free space pool.
• A subdisk in a mirrored, striped, or RAID-5 volume should not be moved to a disk that
already contains a copy or part of that volume.
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4. Choose Subdisks > Split (menu) or Subdisk Split (Command Launcher).

5. Complete the Split Subdisk dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Joining Subdisks
This procedure joins two or more subdisks together to form a single, larger subdisk.
Subdisks can only be joined together if they belong to the same volume and occupy
adjacent regions of the same disk and mirror.

▼ To join subdisks

1. Select the volume with the subdisks to be joined.

2. Choose Show Layout.

3. In the Volume Layout Details window, select the subdisks to be combined into a
single subdisk.

4. Choose Subdisks > Join (menu) or Subdisk Join (Command Launcher).

Disk Group Name: The name of the disk group that contains the subdisk to be
split.

Source Subdisk: If the correct subdisk name is not already displayed in this
field, type the subdisk’s name or click Browse to select the
subdisk.

Number of Subdisks: Type the number of subdisks into which the subdisk should
be split.

Notes:

• The name of the first subdisk remains the same as the selected subdisk. Other subdisks
are automatically named by the Volume Manager.
• The new, smaller subdisks occupy the same regions of the disk that the original subdisk
occupied.
• The original subdisk must contain a sufficient number of sectors for the specified split
to work.
• A log subdisk cannot be split.
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5. Complete the Join Subdisks dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Adding a File System to a Volume
This procedure places a file system on an existing volume and mounts the file
system. This also updates the file system table file, if necessary.

▼ To add a file system to an existing volume

1. Select the volume to contain the file system.

2. Choose Volumes > File System > Add (menu) or Volume Add File System
(Command Launcher).

3. Complete the File System dialog box as follows:

Disk Group Name: The name of the disk group that contains the subdisks to be
joined.

Source Subdisks: If the correct subdisk names are not already displayed in
this field, type the subdisk names or click Browse to select
the subdisks.

Joined Subdisk Name: Type the name of the new, combined subdisk.

Notes:

• Only contiguous subdisks on the same disk can be joined.
• The subdisks to be joined must belong to the same volume and mirror.
• For a striped volume, the subdisks must be in the same column.
• At least two subdisks must be specified.
• The joined subdisk name can be the name of one of the subdisks being joined.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Mount Point: Type the mount point for the file system.
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When you have provided all necessary information in the dialog box, click Ok.

Mounting a File System on a Volume
This procedure mounts a file system that already exists on a volume and updates the
file system table file, if necessary.

▼ To mount a file system on an existing volume

1. Select the volume that contains the file system to be mounted.

2. Choose Volumes > File System > Mount (menu) or Volume Mount File System
(Command Launcher).

3. Complete the Mount File System dialog box as follows:

FS Type: Select the file system type.

Options • To mount the file system automatically at system startup,
select Mount at Boot. If this is selected, the file system table
file will also be updated at system startup.
• To specify mount  options, click Mount Details and specify
the appropriate options in the Mount Details dialog box.
• To specify mkfs  command options, click Mkfs Details and
specify the appropriate options in the Mkfs Details dialog
box.

Notes:

• When the file system is mounted, the file system table file is automatically updated.
• If the path specified for the mount point does not already exist, it is created.
• The mount point must be an absolute pathname (that is, it must begin with / ).

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.
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When you have provided all necessary information in the dialog box, click Ok.

Resizing a File System
This procedure changes the size of a file system and the underlying volume. If users
require more space, you can use this procedure to increase the size of the file system.
If a vxfs  file system is too large and you need the space elsewhere, you can use this
procedure to shrink the file system.

▼ To resize a file system on a volume

1. Select the file system to be resized.

2. Choose File Systems > Resize (menu) or File System Resize (Command Launcher).

Mount Point: Type the mount point for the file system.

Options: • To mount the file system automatically at system startup,
select Mount at Boot. If this is selected, the file system table
file will also be updated at system startup.
• To specify mount  options, click Mount Details and specify
the appropriate options in the Mount Details dialog box.

Notes:

• The specified volume must contain a file system.
• The file system table file is automatically updated.
• If the path specified for the mount point does not already exist, it will be created.
• The mount point must be an absolute pathname (that is, it must begin with / ).
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3. Complete the Resize File System dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Creating a Snapshot Copy of a File
System
This procedure prepares a vxfs  file system for online backup by creating a snapshot
copy of the file system. This is done by creating a new volume, mounting a snapshot
file system on the new volume, and copying the contents of the original file system
to the snapshot file system. The snapshot file system is a consistent copy of the
original file system at the time the snapshot was made. You can use the snapshot file
system to make a backup of the original file system at a convenient time. After the
backup is made, you can remove the snapshot file system (by removing the
underlying snapshot volume).

File System Name: If the correct file system name is not already displayed in
this field, type the file system’s name or click Browse to
select the file system.

Specify one of the following:
• To increase the file system size by a specific amount of
space, use the Add By field to specify how much space
should be added to the file system.
• To decrease the file system size by a specific amount of
space, use the Subtract By field to specify how much space
should be removed from the file system.
• To specify the new file system size, type the size in the
Desired Size field.
To specify a size unit, attach an s  (sectors), k  (kilobytes), m
(megabytes), or g (gigabytes) to the size.

Notes:

• When the file system is resized, the underlying volume is also resized.
• Only vxfs  file systems can be reduced in size.
• The file system to be resized must be mounted.
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▼ To create a snapshot copy of a file system’s data

1. Select the file system to be backed up.

2. Choose File Systems > Snapshot (menu) or File System Snapshot (Command
Launcher).

3. Complete the File System Snapshot dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Unmounting a File System on a Volume
This procedure unmounts a file system.

▼ To unmount a file system on a volume

1. Select the volume containing the file system to be unmounted.

File System Name: If the correct file system name is not already displayed in
this field, type the file system’s name or click Browse to
select the file system.

Snapshot Mount
Point:

Type the mount point for the snapshot copy of the file
system.

Snapshot Size: Type the size of the snapshot copy of the file system.

Options: To place the snapshot on a specific disk(s), click Assign
Disks and select the disks you want to use.

Notes:

• The file system snapshot task is only available for vxfs  file systems.
• The snapshot file system is an exact copy of the original file system at the time the
snapshot was created.
• After you create the snapshot copy of the file system, remember to back it up to tape or
some other media. Remove the snapshot file system when it is no longer needed.
• Users can continue to use the original file system during this snapshot backup
procedure.
• Refer to the vxfs  documentation for guidelines on choosing the snapshot file system
size.
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2. Choose Volumes > File System > Unmount (menu) or Volume Unmount
(Command Launcher).

3. Complete the Unmount File System dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Checking a File System on a Volume
This procedure checks an unmounted file system on a volume for consistency (using
the fsck  command). This procedure can also attempt to repair the file system, if
necessary.

▼ To check a file system on a volume

1. Select the volume containing the file system to be checked.

2. Choose Volumes > File System > Check (menu) or File System Check (Command
Launcher).

3. Complete the Check File System dialog box as follows:

When you have provided all necessary information in the dialog box, click Ok.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Notes:

• The specified volume must contain a mounted file system.

Volume Name: If the correct volume name is not already displayed in this
field, type the volume’s name or click Browse to select the
volume.

Options: • To check and attempt to repair the file system, click Check
And Repair.
• To check the file system without repairing it, click Check
With No Repair.
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Notes:

• The specified volume must contain a file system. The file system should be unmounted.
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Glossary

alert An indication that an error or failure has occurred on an object on the system.
When an object fails or experiences an error, an alert icon appears.

alert icon An icon that indicates that an error or failure has occurred on an object on the
system. Alert icons usually appear in the status area of the main window and
on the affected object’s group icon.

Alert Monitor A window that provides information about objects that have failed or
experienced errors.

browse dialog box A dialog box that is used to view and/or select existing objects on the system.
Most browse dialog boxes consist of a tree and grid.

button A window control that the user clicks to initiate a task or display another
object (such as a window or menu).

check box A control button used to select optional settings. A check mark usually
indicates that a check box is selected.

children Objects that belong to an object group.

Command Launcher A window that displays a list of tasks that can be performed on Volume
Manager or other objects. Each task is listed with the object type, task (action),
and a description of the task. A task is launched by clicking on the task in the
Command Launcher. The Command Launcher can be separated from or
attached to the main window.

command log A log file that contains a history of Volume Manager Storage Administrator
tasks performed in the current session and previous sessions. Each task is
listed with the task originator, the start/finish times, the task status, and the
low-level commands used to perform the task.

dialog box A window in which the user submits information to the Volume Manager
Storage Administrator. Dialog boxes can contain selectable buttons and/or
fields that accept information.

dock To separate or attach the main window and a subwindow.
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graphical view A window that displays a graphical view of objects. In the Storage
Administrator, the graphical view is called the Volume Layout Details window.
See Volume Layout Details window.

grid A tabular display of objects and their properties. The grid lists Volume
Manager objects, disks, controllers, or file systems. The grid displays objects
that belong to the group icon that is currently selected in the object tree. The
grid is dynamic and constantly updates its contents to reflect changes to
objects.

group icon The icon that represents a specific object group.

launch To start a task or open a window.

main window The main Volume Manager Storage Administrator window. This window
contains a tree and grid that display volumes, disks, and other objects on the
system. The main window also has a menu bar, a toolbar, and an optional
Command Launcher.

menu A list of options or tasks. A menu item is selected by pointing to the item and
clicking the mouse.

menu bar A bar that contains a set of menus for the current window. The menu bar is
typically placed across the top of a window.

object group A group of objects of the same type. Each object group has a group icon and a
group name. In the Storage Administrator, object groups include disk groups,
disks, volumes, controllers, free disk pool disks, unititialized disks, and file
systems.

object tree A dynamic hierarchical display of Volume Manager objects and other objects
on the system. Each node in the tree represents a group of objects of the same
type.

popup menu A context-sensitive menu that only appears when you click on a specific object
or area.

properties window A window that displays detailed information about a selected object.

radio buttons A set of buttons used to select optional settings. Only one radio button in the
set can be selected at any given time. These buttons toggle on or off.

scroll bar A sliding control that is used to display different portions of the contents of a
window.

Search window The Storage Administrator search tool. The Search window provides a set of
search options that can be used to search for objects on the system.

Selected menu A context-sensitive menu that changes its name and menu options to match the
type of object that is selected. By default, the Selected menu is greyed out.
When an object is selected, the Selected menu is renamed and provides access
to tasks appropriate for the selected object.
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status area An area of the main window (below the menu bar) that displays an alert icon
when an object fails or experiences some other error.

splitter The vertical bar that separates the object tree from the grid.

task properties
window A window that displays detailed information about a task listed in the Task

Request Monitor window.

Task Request
Monitor

A window that displays a history of tasks performed in the current Storage
Administrator session. Each task is listed with the task originator, the task
status, and the start/ finish times for the task.

toolbar A set of buttons used to access various Volume Manager Storage Administrator
windows. These include another main window, a task request monitor, an alert
monitor, and a search window. The Dock button separates the toolbar from the
main window or reattaches it to the main window.

tree A dynamic hierarchical display of objects on the system.
See object tree.

ow
window A window that displays a graphical view of a volume and its components.

Tasks can be performed on objects in this window. The objects displayed in this
window are not automatically updated when the volume’s properties change.
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Index

A
accessing tasks, 27
adding disks to Volume Manager, 51
adding file systems to volumes, 96
alert monitor, 46
alerts, 8, 46

detecting, 46
icons, 47
monitoring, 46

Alerts button, 7

B
backup

file system, 99
boot disk, 52

mirroring, 57
setup tasks, 9

browse dialog boxes, 31
buttons

in dialog boxes, 31
toolbar, 7

C
checking file systems, 101
color

preference settings, 41
Command Launcher, 8, 29
command log, 35

commands
displaying, 33
viewing, 33

concatenated volumes, 74, 75
Console menu, 5
Create menu, 5, 27
creating disk groups, 62
creating file systems, 96
creating volumes, 74, 75, 76, 78, 79

D
deporting disk groups, 64
destroying disk groups, 67
dialog boxes, 31

browse, 31
buttons, 31
input size units, 32
selecting objects, 31

dirty region logging, 83
disabling mirrors, 90
disk group name

changing, 63
disk group tasks, 49

roadmap, 50
disk groups

adding disks, 51, 53
creating, 62
deporting, 64
destroying, 67
importing, 65
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moving, 68
preventing access, 64
recovering volumes, 67
removing, 67
removing disks, 60
renaming, 63
restoring access, 65
task roadmap, 50

disk names
changing, 54

disk setup tasks, 9
disk task roadmap, 50
disk tasks, 49

roadmap, 50
disks

adding, 51
adding to disk group, 51, 53
alternate boot disk, 57
boot, 52, 57
evacuating, 58
free disk pool, 5
hot-relocation spares, 54
maintenance tasks, 10
mirroring, 57
moving contents, 58
new, 51
offline, 55
online, 56
preventing access, 55
recovering, 59
removing, 60
renaming, 54
replacing, 58
restoring access, 56
root, 52
task roadmap, 50
uninitialized, 5

displaying commands, 33
displaying DMP nodes, 61
displaying object properties, 25
displaying objects, 20
DMP nodes

displaying, 61
Dock button, 7
Dynamic Multipathing nodes, 61

E
errors

see alerts
evacuating disks, 58

F
file system size

changing, 98
file system task roadmap, 73
file system tasks, 71

roadmap, 73
file systems

and volumes, 96, 97
backup, 99
checking, 101
creating, 96
maintenance tasks, 10
repair tasks, 11
repairing, 101
resizing, 98
setup tasks, 9
snapshot copies, 99
task roadmap, 73
unmounting, 100

fonts
preference settings, 40

free disk pool, 5

G
graphical view, 20, 22

preference settings, 43
grid, 5, 20, 21

preference settings, 42

H
help, 6
Help menu, 6
hot-relocation, 54
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I
icons, 11

alerts, 47
errors, 47

importing disk groups, 65
input

size units, 32
installation, 9

J
joining subdisks, 95

L
logging, 83

disabling, 92
logs

adding to volumes, 83
command log, 35
disabling, 92
DRL, 84
RAID-5, 84
removing, 92
task log, 35

M
main window, 3

preference settings, 40
main window status area, 8
maintenance tasks, 10
menu bar, 5

accessing tasks, 27
menus, 5, 27

Console, 5
context-sensitive, 6, 28
Create, 5, 27
Help, 6
Options, 5, 37
popup, 28
preferences, 5, 37
Selected, 6, 27
Window, 6

mirror tasks, 71
mirrored volumes, 75, 79
mirroring disks, 57
mirroring volumes, 79, 82
mirrors

adding to volumes, 82
detaching, 90
disabling, 90
removing, 91
repairing, 89

monitoring alerts, 8, 46
monitoring tasks, 33
mounting file systems, 97
moving disk groups, 68
moving subdisks, 93

O
object properties

displaying, 25
in grid, 21

object properties window, 20, 25
object tree, 4
objects

displaying, 20
searching, 45
selecting, 20, 31
sorting, 22
viewing, 20

offline disks, 55
online disks, 56
Options menu, 5, 37

P
plexes

see mirrors
popup menus, 28
preferences, 37

color, 41
fonts, 40
general, 39
main window, 40
Options menu, 5
setting, 5, 37
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shortcuts, 44
toolbar, 42
tree and grid, 42
volume layout details window, 43
window size, 42

preferences window, 37
properties, 25

in grid, 21
in properties window, 25

properties window, 20, 25

R
RAID-5 logging, 83
RAID-5 volumes, 75, 78
recovering disks, 59
recovering volumes, 59, 67, 88
recovery, 11

disk, 59
volume, 59, 67, 88

recovery tasks, 10
remote administration, 2
removing disk groups, 67
removing disks, 60
removing logs, 92
removing mirrors, 91
removing volumes, 93
renaming disk groups, 63
renaming disks, 54
renaming volumes, 82
repairing mirrors, 89
replacing disks, 58
resizing file systems, 98
resizing volumes, 81
root disk, 52

mirroring, 57
setup tasks, 9

running tasks, 27

S
Search button, 7
search window, 45

searching, 45
security, 2, 16
Selected menu, 6, 27
selecting objects, 20, 31
setup tasks, 9
shortcuts

for preference settings, 44
size units

input, 32
snapshot copies of file systems, 99
snapshot copies of volumes, 86
snapshots, 86, 99
sorting objects, 22
spare disks, 54
splitter, 5
splitting subdisks, 94
starting the Storage Administrator, 17
starting volumes, 86
status area, 8
stopping volumes, 85
Storage Administrator, 1

features, 2
installation, 16
main window, 3
starting, 17

striped volumes, 75, 76
subdisk tasks, 71
subdisks

graphical view, 22
joining, 95
moving, 93
splitting, 94
viewing, 22

T
Task button, 7
task history, 33
task launcher, 8
task log, 35
task monitor, 33
task request monitor, 33
tasks

accessing, 27
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Command Launcher, 8
disk, 49
disk group, 49
disk maintenance, 10
disk setup, 9
displaying, 33
file system, 71
file system maintenance, 10
from Command Launcher, 29
from menus, 27, 28
list, 9
maintenance, 10
mirror, 71
monitoring, 33
properties, 34
recovery, 10
repair, 10
roadmap, 9
running, 27
setup, 9
subdisk, 71
underlying commands, 34
viewing, 33
volume, 71
volume maintenance, 10
volume recovery, 11
volume repair, 11
volume setup, 9

toolbar, 7
Alerts button, 7
Dock button, 7
preference settings, 42
Search button, 7
Task button, 7
Volume Manager button, 7

tree, 4, 20, 21
preference settings, 42

U
uninitialized disks, 5
unmounting file systems, 100
user preferences, 37

V
viewing commands, 33
viewing objects, 20

graphical view, 22
properties, 25
tree/grid, 21

volume layout details window, 22
preference settings, 43

Volume Manager Storage Administrator, 1
volume name

changing, 82
volume size

changing, 81
volume task roadmap, 72
volume tasks, 71

roadmap, 72
volumes

adding file systems, 96
adding logs, 83
adding mirrors, 82
and file systems, 96, 97
backup and restore, 88
concatenated, 74, 75
creating, 74, 75, 76, 78, 79
detaching mirrors, 90
disabling, 85
enabling, 86
graphical view, 20, 22
joining subdisks, 95
maintenance tasks, 10
mirrored, 75, 79
mounting file systems, 97
moving subdisks, 93
preparing to restore, 88
RAID-5, 75, 78
reattaching mirrors, 89
recovering, 59, 67, 88
recovery tasks, 11
removing, 93
removing logs, 92
removing mirrors, 91
renaming, 82
repair tasks, 11
repairing mirrors, 89
resizing, 81
setup tasks, 9
snapshot copies, 86
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splitting subdisks, 94
starting, 86
stopping, 85
striped, 75, 76
task roadmap, 72
unmounting file systems, 100

W
Window menu, 6
windows

alert monitor, 46
graphical view, 22
main window, 3
object properties, 20, 25
preferences, 37, 38
resizing, 5, 42
search, 45
setting size preferences, 42
task request monitor, 33
volume layout details, 22


